Bond bridge intigration


All the fans were imported.

When I try to turn on a fan I get that error message.

I need you to be really clear about this.

If you now delete ALL the Homey fan devices (for Bond Bridge Integration), and then add only a single fan, do you still get the same error message of “Could not get device by ID” ??

Ok i did exactly as you requested.

  1. Removed all fans.
  2. Added bsck only one fan.
  3. Same results with sane error message.

The token and IP must be correct since the app is telling me valid token when i check it in the app.

I also restated the app and got the same result.

Let me know what else you want me to try.

Here is the pic of the app with only one fan loaded.

Unfortuntely I’ll need you to run the development version of the bond app and share the result of the console output with me…

Step 1, install the homey developer tools
$ npm install -g homey

Step 2, download the App using the Code → Download Zip option.
[GitHub - gslender/com.gslender.bondbridge]

Step 3, where the folder for the app is installed, run this command
$ homey app run -r

Then capture the output of the console when you try to start/stop a fan. It should dump the error to the console or at least give me some clue as to what the issue is.

I’m down to help out in any way I can but I’m just an tech enthusiast that just happens to understand scripts and code due to constantly reading up on things I interact with that I want to make sense of.

so wait, even with just one fan registered to the bond app and added on to homey, it still doesn’t work?

I’m getting the exact error as @Tom_Tschuor I’ll send the diagnostic report via app

but i’ve tried with two fans installed on the bridge and added on the homey and with just one fan added, it still states the same it can’t identify the device id. Does it require the device ID to be pulled? I’m not using cli right now but I can try later.

Also, SBB was able to be added but has the exact same issue regarding homey not being able to find it.


I did the following:

  1. Removed all fans from Homey Pro.
  2. Installed one fan into honey pro.
  3. Tried to turn the fan on and got the error message.

I did not remove all the fans from the Bond Bridge since I need them connected to control them.

I think I have discovered the bug. Thanks for the diagnostic log. New app to be released soon

v1.0.6 has been released that hopefully fixes the fan bug

1.06 works!!! At least for one fan. Will add more fans and see if it works.

It works with all fans! Nice job thanks

How do I buy you a drink. Send me your paypal or venmo info.

1 Like

All good. Happy to help grow the Homey community. Spread the word as then we all benefit from a stronger community and support for devices and apps.