Authentication fails for several devices

Since a few weeks I cannot connect any devices that need to be connected via an api anymore. For instance, when I try to connect to my Sonos devices, I get into the sonos authentication page, then redirected back to Homey and then after a while I see no devices appear.

The same problem when I try to connect to Spotify. And when I try to connect to Honeywell Lyric, I get an error after authentication as shown in the right most screenshot below.

It looks like there is something wrong with retreiving oauth tokens. The native apps of the suppliers are working.

I tried to delete the apps and install them again. Also a system reboot. But no success yet. I can try to do a factory reset, but I have lots of flows and don’t want to loose them. My house will get very dark these days :sweat_smile:.

I have found the solution: I did a factory reset anyway, but I activated the backup system first. After the factory reset and putting the backup back, it worked again.