Aqua Temp pool heater

Sure. Now I got it. Thanks again in advance for the support! How do we proceed? What do you need from me? Best regards.

Hi, I am not able to connecting my device. I have logged in using my e-mail and password in the app. When I try to enter the device, I get the following error message: Cannot read properties of undefined (reading ‘device_code’)

Do someone have any idea what i should do?

Send me a PM so I can look at the credentials and verify.

Hi @Ludwig_Hallgren i have the same issue as the ones above (cannot read properties of undefined).

Can you assist please?

Thanks you very much!

Can’t really test right now. Still winter here so no pool on.

Can i send the logs? Maybe there is a clue in there.

Thanks!

Yes please do.

Here you go:
7ad19802-642c-42a5-ade3-649d78baec35

Let me know if you need anything else or want me to test something.

Thanks a lot @Ludwig_Hallgren !!

Same issue you don´t get a token back from Aqua temp API. If you send me the credentials in a PM I can verify against their API. They might have a new API on newer model.

Hello

Thanks for creating the APP, i am unfortunately having the same issue. I get i “Cannot read properties of undefined (reading ‘x-token’)” aswell.

Is there any way this can be fixed ?

/michael

Hi Ludwig, sorry to add to the chorus, but I have the same issue “Cannot read properties of undefined (reading ‘x-token’)”. My credentials with AquaTemp work for the Android app.
I am adding here so I see the solution when there is one!
Cheers

I can confirm that they have changed API endpoint and password encryption which means I have to get some time to update the app. Really busy time at work right now as well but hopefully get some coding time in during traveling the coming month.

2 Likes