Apple Siri Shortcuts not working anymore?

In my iphone I use Siri to start some favorite homey Flows. Since a few days this does not work anymore, in Dutch “de taak start een homey flow wordt niet ondersteund op iphone”, or in English:" the task start Homey flow is not supported on Iphone".
This worked fine until a few days ago. I have uninstalled and reinstalled the homey app, no success. IOS vs 16.3.1
Anyone else has the same experience ? I guess the problem is not on the homey side but on the apple side. Did a reboot of my iphone, did not help.

In my furhter search of a solution, I installed the latest IOS version 17.2.1. Now the tasks work again, (opdrachten), from the screen, but still not from Siri. Siri is now complaining that I need to install the so called Woning app (house app). So still trying to figure out how to start a simple task in Siri, Apple changed something, affecting the easy voice control of Homey flows.

Well after the IOS update and having some patience, after about 15 minutes magically Siri lets me start Homey flow again. So problem can be fixed by IOS update, and 15 minutes of patience.


I’m experiencing the same problem. I use the shortcuts app to determine awake/asleep for the me and the wife. Quite annoying it won’t start a flow.

I also updated to the latest IOS. But now iOS shortcuts won’t let me re-create te flow I used. Instead the iOS app freezes and crashes as soon as I try to select “homey” from where I try to choose my favorite flow.

Probably this problem occurs on the iOS side. Anyone else experiencing this problem ?

No problem with:
— iPhone 12 Pro Max
— iOS 17.2.1
— Homey App

My solution was : update IOS to 17.2.1 (latest), remove and reinstall homey app. After that this should work.
Iphone Xs.
The voice message from shortcuts is “Homey Flow gestart” and this is if I remember correctly a different message than it gave earlier.
These kinds of app-chains that evolve independently have the nasty habit of sometimes suddenly not working anymore. I am glad we don’t use domotics to control a nuclear power plant.

Just to add another solution I tried: create a flow that is started by a logic event (a so called webhook), than you can use a URL to start a flow. You can also start the URL from the Shortcuts in IOS, the name of the shortcut action you can start from Siri. I tried this: Request your first API in Shortcuts on iPhone or iPad – Apple Support (UK)
And needed to use the part that says. get content of URL. The URL you then can replace by the webhook url you can copy from your flow in homey. Explained here

In my case my webhook url looks like
123456789 is in my real url the homey id you can find in the settings.

The advantage is that you now have a dependency of IOS to opening webhook URLS instead of IOS to the Homey app. I think Apple is likely to make sure in their IOS updates that opening URL’s keeps working. So this solution might be more stable, less subject to app-chain failures.

Thanks a lot for your reply! Will definitely try this tomorrow!

I forgot what a pain it was to turn off every light when you go to sleep :joy: #firstworldproblems

I have the same problem using the Shortcuts App. Reinstalling the Homey App didn’t help. Selecting Homey as a target always crashes setting up a new automation (see Video).

I just wanted to create Shortcuts with my new RFID Stickers. Looks like this won‘t work…

Same here.

An alternative way to get that working is using webhooks (there’s a built-in Logic card that can trigger a flow when iOS opens a particular URL).

Yeah, that or creating a Shortcut first and then use this Shortcut in an Automation.

However, this is a bug with the Homey App that should be fixed by Athom :-/

This works. Thanks for the workaround. Easier than the webhook :slight_smile: