[APP] TP-Link Kasa Smart - by Athom

For the Community Developed App: [APP][Pro] TP-Link Smart Devices - central topic

Central topic for questions / discussing the Athom App:

Hello i am a new Beta user here, and i am having the same issue with KP115, I can not add them, i’ve tried HS110 but it doesn’t find them, is there another way to do it or will I need to wait until the update?
My EP10 and HS103 work but i also noticed my 4 KL125 light bulbs don’t show up?


OK, missing a number of Kasa devices. I’m not sure how this works but here are more that should be there for Kasa:


A coloured light bulb, an LED light strip and a couple of light switches…standard and 3 way.

1 Like

Add the KP125 to your list, as this outlet is the most popular in the US. Hopefully someone picks up your list :slight_smile:

I’m not holding my breath. I received a response to a support inquiry with the Homey Folks/Developer who has built the integrations that exist today. It didn’t sound like there was much interest there in taking it further…and this struck me as odd as the dimmer switch is present but the standard 2 and 3 way switches were not. Those should be straight forward given a dimmer has more feature/functions.

The did however recommended I reach out to Kasa as ultimately they should develop the integrations. The resulting thread can be found here: Homey Support for Kasa Devices - Smart Home Community

Maybe others can go and add their voice. Sadly, I will likely replace the Kasa products before anything is done about it.

is this about the app TP-Link Smart Devices App for Homey | Homey by @anne
or about TP-Link Kasa Smart App for Homey | Homey by Athom ?


This is in reference to the Athom developed App which is the only one available to Homey Bridge users.

I expected but let’s keep it in the correct Topic,
So i Created a new Topic as the other Topic is for the discussing of the App by a hard working Community developer.

1 Like

Sure, not a problem. I didn’t realize there were two apps for the same vendor’s products. Just received my bridge late last week and now learning the ropes. Not as broadly supported, or as straight forward, as the marketing would lead one to believe…but hoping it gets there!

Hey guys,
I want to know how much power my heat pump consumes on a daily basis so I’ve plugged it in a HS110 smart outlet.

I noticed that the power consumption of my HS110 smart plug is totally different in the Homey app than it is in the Kaza app (from Tp-link itself).
The homey’s value seems to be the incorrect one.
Anyone of you who knows where the problem is caused and how to get it solved?

(for the record: its the only device plugged in to it and then directly on the home grid so no other device is accidentally being measured too)

The Kasa app worked flawlessly when I only had two light switches. I recently added 4 WiFi plugs and now I’m getting random “rate limited” messages and devices are not available in the Homey dashboard (shows errors) If I try and switch them I get “rate limited” messages. They work fine in the Kasa app and work fine for a while after I restart the Kasa app in Homey.

1 Like

Not sure if this fixed the issue…but I upgraded the firmware of the Kasa devices using the Kasa app and I haven’t had the “rate limited” error in a couple of days…