[APP][Pro] TP-Link Smart Devices - central topic

For the Athom app for Homey (beta) and Homey Pro [APP] TP-Link Kasa Smart - by Athom

This is the new central topic for the TP-Link smart devices app

Supported Devices:

Smart plugs: HS100, HS110, HS200
Smart lights: LB100, LB110, LB120, LB130

The library used also supports HS105, LB200 and LB230. These devices will probably work without issues if added as HS110, LB100 or LB130 respectively.

[UPDATE]: The SDK2 rewrite, v0.1.0, has been submitted to the app store. This version includes support for dynamic IP addresses.

FYI, I have submitted the SDK2 rewrite of the TP-Link app to the app store.

Approval takes a while these days, if you want you can install the app via the CLI (search ‘CLI HOWTO’ or something similar on the forum). The app repository can be found here: GitHub - abaretta/nu.baretta.tplink: Athom Homey app for the TP link HS100/HS110/HS200 smart wall plugs and LB100, LB110, LB120 and LB130 smart LED lights..


Just ordered 2x HS100 because the remote is too far for zwave so this will be the solution.
They are working as expected.
now waiting for the new version so i can switch and test to homey 2.0

1 Like

MY HS110 smartplugs lose connection and stop working in Homey.

Hi Wout,

Can you provide more details such as which version of Homey, which version of the app, etc.?

The first thing to check is if the ip address used by the plug has changed, the app does not automatically rediscover plugs if this happens. This is most likely your problem.

You can add a plug and see if any are discovered by the app at ‘new’ IP addresses. You can then either use the newly discovered ones, which means you lose the insights data, or change the IP address in the settings of your current plugs. :+1:

Homey Firmware Versie: 1.5.13
And 1.3.3 build 70 ios

IP adresses are the same

I have no idea what the problem may be, you are still not providing a lot of detail. The Homey version is clear, ‘1.3.3 build 70 ios’ sounds like an old version of the Kasa app, for Apple, but I am guessing here.

What have you tried so far? Do the plugs still work with the Kasa app? Have you tried re-adding the plugs in Homey, or restarting the app? You do realize that I am just a Homey user who happened to make a few apps, I am not getting paid to make apps or support them? No-one is donating anything either I might add.

v0.0.17 of the Homey app works for me with the latest TP link firmware for the plugs, and it appears to work for ~275 other users as well, so it is not a general/common problem.

@Aart_Hardeman, SDK1 apps may work on Homey V2. The TP Link app does not have any features which are unsupported in V2, so I am looking forward to the first person testing the app on V2 :wink:

In the meantime I have started some work on an SDK2 version of the app, so it will come at some point, probably before V2 is stable anyway.

I use Kasa version 2.7.1 build 594.

I Kasa it works fine.
After re adding it works fine for a while.

Restarting the app doesn’t make a difference? And you say the IP address remains the same, so you can ping the plugs after they stop working in Homey? How long does it take for the plugs to become unresponsive?

What you can do is download the app from the github link in the app store and install it via the ‘cli-method’. This will give debugging output which will probably shed some light on the cause of the problem.

I have looked in the guthub link.
But i dont understand what u mean with CLI method.

Have them reset and it works now.
But one of them works with the christmass tree. That one works bad.
Sometimes no respond.

Over to Homey 2.0
Zero problems with the app.0.0.17. Tnx.

Mmm, after publishing the SDK2 version in the store I am getting (Homey v2.0.0) crash reports… The app has been verified on Homey 1.5.13 as well as v2.0.0, but possibly something is going wrong with certain device types. Basically there is one driver for all the plugs, and another one for the bulbs. The other devices use the same driver with a subset of capabilities.

The crash reports are caused by (mainly) ‘connection refused’ errors, but I can’t tell for which devices. Let me know if you have any issues, and please give details on when it happens. And perhaps try the usual, restarting the app, removing and adding a device, etc.

I wonder/suspect if the issue may be affecting hs100 plugs and lb100/110/120 bulbs, please confirm if you have issues with one of these devices (or not, that could helpful to know as well ;-).

Hey anne, thank you for the update!

After update v1 this app crashes everyday.
After a restart it will work for a day.
I use three HS110 and sadly I updated to homey V2
With homey 1.5 I had no problems?

Hi Jimmy,

Each time an app crashes the developer gets a crash report in the mail. As mentioned above, I have seen several, unfortunately the crash reports aren’t very informative… So it’s good you post it on here, otherwise I can only guess what’s going on. In most cases the app gets a ‘connection refused’ or the TP Link device becomes unreachable.

I can’t reproduce the problem myself, apparently only a minority of users run into the issue, and they are all on Homey V2 (I haven’t updated yet).

The issue may be related to the feature I added that allows the app to deal with dynamic IP’s. I will update the app with an option to turn this on or off (by default leaving it off), to see if that makes a difference.

Lucky you. I have updated and all of my TP-Link smart plugs are unusable now. Any way to downgrade to the old Homey?

You can’t downgrade to 1.5.13 unfortunately.

You aren’t very specific about what exactly is happening with the plug, I guess the app crashes?

I will probably have a fix for the issue that crashes the app shortly.

The app crashes constantly as I already mentioned. Even trying to use any of plugs causes the crash. hence the are not usable at all. Pity you can’t downgrade. I have other devices e.g. Fibaro RGBW switch, Heatmiser hotwater controller they just stopped working. This means 3/4 of my all devices being controlled by Homey are peace of junk at the moment.

I meant piece - not peace.

@rafi And you have contacted athom about this right?

Yes, I have. On all of the issues. No fix so far.