[APP][Pro] Victron Energy

Thank you for your quick reply :+1:t3:.

Keep us posted on the progress. No hurry here, as you have said, it’s only for scheduled charging. Can manage with the features on hand in the app so far.

SOLVED after rebooting the GX Cerbo

The app is great, thank you, but now, Homey cannot find the GX on port 502 anymore. The IP address is right. Homey recognized the GX a few days ago, but now, it says could nt connect to host … on port 502.
Modbus TCP has enabled.

What is going wrong?

1 Like

Hi at all,

I am struggeling with the connection of my cerbo GX to Homey.
I activated Modbus - ok
I know the IP and also the port - ok
I know the number for the batterie - ok
But I do not have a number for VE

I connectet my MPPT and my shunt with VE direct.

I cant find a number in services and get the message :
Connected successfully to GX device xxxxxx but com.victronenergy.vebus Unit ID 224 is invalid.
I tried the 224 because it is my mppt where the battery is connected.

I hope I could explain my challenge and hope the sombode can help me.
I only need the SOC of the battery for my Homey Flows :wink:


Maybe I’m not following the entire problem, but you tried following the instructions in the first post of this thread? To find the Unit IDs.

Good Morning Richard,

yes - I followed the instructions.
I found the Unit IDs but I can’t find a unit ID for com.victronenergy.vebus.
I only use my Credo GX together with a shunt and a solar charger.
The inverter is not connected with the cerbo gx because I use an on grid inverter to feed my inhouse grid from the batterie.
That’s why I think I can’t found the ID for com.victronenergy.vebus because for the system it seems that I don’t use an inverter.
Is ist possible to use the App only for the readout of the battery.
The ID for com.victronenergy.battery exist.

I’m afraid, that you can’t help because of the aim of the APP. Normally this system is (of course) used with an victron inverter and the ID for com.victronenergy.vebus is essential.
I use it as in the attached picture (Is it visible ?). I added a Credo GX to this “construction” for having connection from the internet.

Thank you very much for you help :wink:

Update: I don’t use the Timer and the relay I always switch on the batterie (the tie grid inverter) per hand.
The solar charger is connected to the Cerbo GX.