[App][Pro] Tuya Cloud

Hi, thank you!

I have an issue which I really can’t understand.

My Wifi smartplug (Deltaco) is connected to the Tuya Smart app on my phone.
This app is linked with Tuya Cloud.
In Tuya Cloud, I can see that device is added.

In Homey, I am not able to add this device through the Tuya Cloud Homey app.

I have changed the dropdown to official only.

Is there anything missing for me for Homey to see this device in Tuya Cloud?

image

Under the Cloud tab > devices:
image

The device is probably not supported to add it as device.
Like I suggested yesterday, you can operate it without adding it as Tuya Cloud device, with the Raw command or tap-to-run workarounds.
Look for it in post #1 of this topic, and have fun!

1 Like

Yeah, unfortunately ;(

I have to look into that later, it’s more complicated to set up.

I use Smart-Life App and connected tuya cloud. all devices are in homey.
The LED Stribes can not dimm over homey only On/Off color change
and next problem. sometimes 1 of the 3 LED Stribes are switched on over the cloud (homey timeline of the decie show so). But nobody of us was using this. Why this happen? Can i see whats happend in the cloud. why someting is switch on the LED?
And why i cant dimm the LEDs over homey

I can try the Smart-Life app instead. It looks similar to the Tuya Smart app though :smiley:

Open this post:

Hi arch4ngel,

Did you see my post and what was your outcome?

Have a nice day.

Greetz Hugo

ok, i will test it, but its show tuja cloud. NO Flow is Use this new devices, so no Flow can controll this LEDs. I only conect it to Smart Life - Tuja Cloud - NO automation. Its still in a cage for pets and still in progress to finish the case, so no flow is needed. Its only to check the connection. Thats why i was wondering that every Day on different times 1 of the 3 LEDs is turn On over the cloud over homey.
But i will check your App.

Hey! Firstly, thanks a bunch! I’ve been away for a few days and unable to do anything.
I’ve created a flow (named Test Flow) “WHEN text event received” with “Device ID, Functionname and Functionvalue” as tags - “THEN Add something to the log” with “Device ID, Functionname and Functionvalue” for Simple LOG.

The only thing I see in Simple LOG app (under App Settings) is my Test Flow. If I choose “Configure app” Simple LOG starts and shows me this (see picture). I cannot see anything reg. power consumption.

What could be the next step?

Hi,

I can see voltage in the Tuya IoT, but not appearing in Homey:

Hi,
I’m having trouble configuring the Tuya cloud app in Homey.
I’ve followed the manual from the 1st post
What i’ve done succesfully so far:

  • Made a project on the IOT tuya page
  • Linked the Tuya Smart app to my project
  • Made an authorization key

But then when I configure the Tuya app in Homey and press save I get the error message “1005 clientID invalid”.
So based on the message I assumed the problem is the username I entered was wrong.
But it’s the same username (emailadress) I use to login to the Tuya Smart app.
Which should be correct according to the manual in the 1st post.

I tried troubleshooting it, and the only thing I noticed is when I remove the domain part from the emailadress in the Username field, I get a different message.:
1106 permission deny
This error was mentioned in the 1st post and had a few solutions.
The problem is not the country code, I checked everywhere and everything is set to Netherland and code 31
Also I already established to link the my app account to the cloud project.

So I’m a bit lost here.
I triple checked all info I’m being asked in the Tuya Homey app and all the info looks to be correct.

Has anyone had the same error (1005) before?
I couldn’t find any info on the error in this post.

Thanks in advance!

No problem at all, I understand. I like to help where possible. Please configure also a receive event for the other two data types boolean and numerical. I need to check what was mine, but as far as I remember my power usage data was numerical.

First think we need to know is if Homey is receiving the data through the api.

From there we can check other thinks.

The device itself was available in Homey and you can use the basic functions from there?

But Voltage is not Power (w - watt) or Current (mA - milliAmpere). Voltage is mostly stable (a standard value of the grid or other device which delivery the energy like a battery) and is not used to measure the device usage. You need watt or ampere to do that.

With two of the above counters you can calculate the other, but in that case you need minimal two of these not only one value.

Sorry but only voltage does not say anything.

1 Like

Thank you! I am the same, where I can help and support of course. For Homey/flows and Tuya I am the on needing help :sweat_smile:

I can see the NAS-WR01W device in Homey, I can control on/off but nothing else.

I have now added flows for Boolean and Numerical also, with the same “THEN”, i.e. with “Device ID, Functionname and Functionvalue” for Simple LOG.
The log itself doesn’t really make any more sense to me, just shows the switch going on or off (true or false).

Can you share your Homey Tuya App Settings? Blur the account name, ID and secret.

Do you have a switch/socket which you can remove and re-add to Homey (maybe it still uses underwater the legacy version instead of the official)?

Remove and Re-add it to Tuya App and IoT as well.

If nothing will change we need to deepdive into the Tuya IoT settings (subscription, project, devices, etc).

Sometimes it seems hard to get it work. I had also strange problems in the first place.

Hi Hugo,
Attached is a picture of the Tuya app settings in Homey.

I have removed and readded the plug that does not show power consumption, from both Homey as well as the Tuya app (which also removes from IoT portal).

I’ve also added another plug just now to see if that would show more things/data. It popped up in Tuya IoT portal directly. Reloaded the Tuya app in Homey to get it added in there as well.
No power consumption data for that plug either.

New firmware version 5.1.0 for the plugs. Updated the newly added plug. After that had it removed from Homey as well as Tuya app/IoT but no difference either.

I am suspecting it has something to do with IoT settings as you said we may need to deepdive in.

And these are the service APIs that I have for my project (aptly named Homey).
I have tried adding APIs Power Management and Power Safety but no difference with them added either.
Did not remove the plug from Tuya app/IoT then though, would that make a difference you think?

Your device is not (yet) supporting power with the API. You have selected the right services and did setup correctly. Other services then the 5 mentioned in documentation are not used, so adding them doesn’t do anything. The power services you selected give access to extra rest API endpoints to query power data, My app uses only status notifications pushed by Tuya to get status info. The raw flows are expose those messages unfiltered.

Your log is not showing power data, those values are not pushed by Tuya somehow. If sockets have power data available when pairing, the power option will be made available for your device. So it’s also possible that in query for pairing the power options is available, but not in status messages. In this case the power is never updated.

Only logging the text messages is enough, the Boolean an numeric are also send as text. The numeric and Boolean flows for receiving are there to use directly the values with correct data type.

Hi @Jurgen_Heine,
I am thinking you are replying to me, right? I could agree what you are writing makes sense.
What does pose a conflict for me is that @HvN is using the same plug (NAS-WR01W as part number) with the same app in Homey and everything else, and he can see power consumption.
This is what him and me are trying to figure out what may be the reason, as it would make sense experience should be identical if setup (both HW+SW) is identical.

Hi,

Will the Tuya-cloud work for this Wifi dimmer from Malmbergs?