[APP][Pro] The Things Network - Make Homey part of a global LoRaWAN Network

Mod Edit

The Things Network App for Homey | Homey

App to connect Homey to The Things Stack

1 Like

Nice to call it TTS, unfortunaly it sounds like Text To Speech


True, renamed.

1 Like

App now released for testing

Instructions for use

1 Like

Well done, I’m hoping to try this out this weekend

Hi! The link for testing seams to goto you dev account and that will not work for us users. Do you have a link to the app for users instead?

And b.t.w. thanks for doing a app for ttn its much appreciated!


Apologies, but looks like the app has limited distribution as it hasn’t been reviewed yet:

When you upload your app, as described above, it’s Draft. You can then release it to Test . This allows users with a link, available in your dashboard, to test your app. Note that apps that never have been reviewed cannot be tested by external users.

If you don’t want to wait you could go through the process of installing the SDK to your computer, cloning the repo & sending it to your homey, but thats a bit of hassle. The app should hopefully be released within 2 weeks.


Nice work! I hope to receive my first loraWan device tomorrow. Can’t wait to play around with it and see how it works with Homey :+1:

Or put it in The Community AppStore!

Seams to be some bugs in it… When i tried to add it with cli i runs for a little while then it stops… From the log i get this…
─────────────── Logging stdout & stderr ───────────────
Warning: Trying to access Homey.env.WEBHOOK_ID but the environment variable has not been set!
Warning: Trying to access Homey.env.WEBHOOK_SECRET but the environment variable has not been set!
[log] 2021-07-08 11:39:37 [App] New key path value (x-user-id): XXXXXXXXXX
Unable to initialize app Error: Missing required parameter: webhookId
at Remote Process

— INFO: com.connector.ttn has been killed —


The app has just been released in the app store so you’ll be able to save yourself all the hassle.

The reason the app failed to build was because of a missing file env.json. Its not uploaded in order to prevent apps sharing webhooks & the ensuing chaos!

Hope you like the app!

Please note there is an issue with the Homey webhook template on the TTN website, I’ve submitted a patch & hopefully it’ll be rectified over the next few days. In the meantime please use the custom webhook method instead.


Had a quick play tonight - I think I’ve got the webhook copied correctly to TTS and also the key path added but I don’t seem to get any flow triggers coming through in Homey. It’s late I’ll try some more tomorrow.

Should I see this web hook registered on my Developer Tools page - (I dont)

(I presume I can leave the ‘and’ condition empty and all triggers would just pass through)


truncated on RHS

I’ll try and verify the web hooks are being triggered from TTS too

The settings that I can see look correct.
No, I don’t think you’ll see a webhook on your developers page.
Correct, no need for any ‘and’ condition.

I’ve check & the app does not trigger unless you include a payload formatter similiar to the script shown here. This is likely your issue. I’ll correct this is the next version.

I’ve tried including the formatter at both the app level and the device level in TTS and I see the payload being formatted correctly but still no trigger into the Homey flows…

I’m going to see if I can confirm the webhooks are being originated from TTS

Do you see any ‘forward uplink data message’ on the ‘live data’ on the TTN console?

Yes … I do

Never tried webhooks in TTS before but I have a feeling the webhook is not being sent by TTS
What’s the best way/tool to emulate a webhook into Homey ?

You could use: https://requestbin.com/

You can setup your own webhook on that service & using the details on TTS/TTN see if your getting any traffic

I will continue playing - I set up a webhook using a youtube tutorial on v3 and tago.io and that worked fine - but it’s using a template. Maybe I will await the template correction on TTN.