[APP][Pro] Synology Surveillance Station 2

Hey @phusebox
can you send a diagnostic report?
You can do that via the mobile Homey app:

More - Apps - Synology surveillance Station 2 - settings wheel right top - send diagnostic report

yes it work now!! Thanks


I noticed that the option snapshot is removed, why is that?
None of my camera’s via SS in homey have no snapshot option anymore, my doorbell flow is broken now because i cannot take a snapshot anymore…

Had the same issue. Restart of the app solved the issue.

1 Like

Hi @B3rt
yes please restart the app and see if that resolves

after app restart it worked again

1 Like

The app keeps loosing connection to my DS218+ (connected locally by IP) once in a while. I have to set it up again (url, port, credentials) to get it connected again. After that I am able to “repair” my camera’s.
Any idea, @martijnpoppen?

@Henk_Renting Hmm no doesnt ring a bell immediately.
Didn;t create this app so it’s a bit harder to debug these kind of scenario’s

I guess you do have a static IP for your DS218?

Yes, it does have a static IP…

@Henk_Renting when it happens again can you send a report? :slight_smile:

Yes, I will. Thanks for the support!

1 Like

On my Kickstarter Homey Pro I’ve been using your Synology app with great pleasure. I connected to my SynoNAS on my local network.
I just upgraded to the Homey Pro early 2023 so had to update to your Synology 2 app.
Like other people I get a certificate error on https. Which is logical since i’m running my NAS locally on a 192.168.x…x domain. The SynoNAS does have a self-signed certificate.

Is there any way to solve this by accepting this self-signed certificate?
Especially since with your old app i did not experience any problems.

Hey @elfrigo
I took this app over last year. So sometimes i have to check too what is possible and whats not :wink:

But as far as i know it should allow all certificates.

Can you send a report after you try to connect it? :slight_smile:

@elfrigo found the issue, will make a fix for that today :slight_smile:


I’ve created and send the report last night. I guess you’ve received?
The problem probably is that for a self signed certificate on a local server the certificate issuer is unknown.
Thank you very much for such a quick look into this problem!

New app update (TEST: 4.1.1):


1: FIX: self signed certificate

If you find any issues, send a report via the mobile homey app

More - apps - Synology Surveillance Station 2 - settings wheel right top - send diagnostic report (put your email in the input field to make it easier)

You can install the test version by clicking the link above and press install

Don’t want to be part of this test version? Install the live version → Synology Surveillance Station 2 App for Homey | Homey

@elfrigo can you install the test version and see if that resolves your issue?

Click this link and press the green install button

@martijnpoppen Just installed the experimental version you’ve linked too. This solves the certificate error. I can add my Synology Diskstation with local signed certificate! Superb! Thx!
Also turning my Syno in Home / Away mode works. So Homey and the NAS can communicate.

Unfortunately the next challenge arises. I can add my cameras from the NAS to homey. But they do no show live footage in Homey. It gives the error below:

Can you send a report @elfrigo

diagnostic report code

1 Like