[APP][Pro] Somfy Tahoma & Connexoon (v3.0.35, test v4.0.2)

We can all reduce the polling frequency, by default this is every 15 seconds imho.

So why my shutters suddenly today do not work or respond any more from the Homey app now?
I get Request failed with status code 401 now.

Maybe restart the app?

For me, version 2.07 works fine now. I logged in and it connected immediately.

I set mine to 100, for me it can be more since I never check the status, I just call scenes on the tahoma box.
Don’t know if there is an possibility to set the interval to ‘never’, but then maybe oauth fails when I call a scene (don’t know the code of the app)

Basicaly for that reason, you answered yourself.

Hi Adrian, I installed testing 2.0.7. and I lost all my scenarios. The list is empty. Thank you very much for looking in it.

I honestly can’t say one way or the other if this is related as according to the email Somfy have given until the the 30th Oct before they will take action so probably not related to that.
If you have just updated the app then it is possible the new version has a bug.
One thing Somfy have been doing is changing the authentication method on users accounts from a cookie access code obtained with a username and password to an OAuth method the needs a client ID and a client secret along with the username and password to obtain a bearer token that has to be placed in a header of every call. Maybe they have switched you account?
My Tahoma account works with both.
Could you check the settings in the Apps - Configure app page as I have been adding new login options to try and help users that could not login before for the same reason.
Make sure to start with the default server and ‘USE NEW OAUTH LOGIN METHOD’ not ticked. If that still doesn’t work then try ticking the new login method.

Athom have offered to talk with Somfy if I don’t have any success.

6 Likes

I would be interested to know what people have set the polling time to?

I had mine set to 5 seconds but I have now increased that to 15.
I can easily set a minimum limit to protect everyone.

1 Like

Ultimate solution: Adrian get contract from Somfy to mainain the official Homey app :smiley:

1 Like

I will look into that but I have not played with scenarios yet so I’m not sure why that could happen.
It might be a side effect of the new method of fetching just the required data instead of everything.

Mine was set to 15, I changed it to 300 (ones every 5 minutes).

2 Likes

The problem is Somfy don’t want to integrate with other systems unless it is on their box.

They did start to bow to consumer pressure about 2 years ago and produced the start of an official API. They updated it once after about 6 months and then just forgot about it. The problem is, it has very limited support for devices. See https://developer.somfy.com/release-notes.

The Homey - Somfy app was produced in June 2017 when here was no official solution and Somfy were adamant there wouldn’t be one.
I took control of this app three weeks ago (talk about bad timing) because the original dev didn’t have the time to spend on it and requests for support for new devices were queuing up. I guess I always knew it was a possibility that Somfy would put an end to it at some point but I didn’t bank on it being so soon.
Just to add that Home Assistant users have also received the same email and that app uses the official API. So it is possible that Somfy just sent that email to all their users.
I have been in contact with the developer of the HA app and, as he is using the official API, he is asking his contact at Somfy for clarification and will let me know the outcome.

Anyway, I have made some big changes to try and resolve the main issue that the email raised (use of GET /setup endpoint) so now I just hope that is enough to satisfy Somfy.

In particular, the GET /setup endpoint is meant to be used once and only once by end-user session and not to regularly refresh the devices data.

Also the email had a glimmer of hope in as much as it said:

We are asking all third-party scripts or application to reduce their polling activity on our API.

So they did not say “stop activity”, just reduce the polling.

3 Likes

207 isn’t working here. 19x velux
Can someone make an api for the velux klf200?

Isn’t working ‘at all’ or just doesn’t find that cover?

If you just need the klf200 added then send me the device log from the Apps - Configure app page.

Thank you very much, that solved the problem. And I am using the new test version 2.0.7 now.
Only still can not add my Light VAR io with the Light Controllers.
I did send the log already though with the lights in bright settings.

I am concentrating on puting the fire out at the moment :wink:
I have a few new devices in the queue to add in and will get to them soon.

2 Likes

Is the login working (green message saying successful), after you save credentials

?

Yes

Did send an errorlog…