[APP][Pro] Somfy Tahoma & Connexoon (v3.0.35, test v4.0.2)

Thanks for the info … yes business savvy, isn’t the big problem that the protocol is very closed? He enjoys a bit of a market monopoly

Hi guys,

Can anyone give me an example of how the queit mode works? I set the status of one velux to quiet, but it was making the same amount of noise when i closed it (by remote, so maybe thats the problem?)

I have never used the setting in the app, but tried quiet operation of my blinds with remote. My experience is that it is marginally less noisy, but also takes more time. I would say it is more annoying since the sound is there for a longer time.

It doesn’t work when you set quiet mode in homey and then use the (non-homey) remote to set the status. Try quiet mode on and then change status inside homey, it should move less fast. Otherwise contact Adrian :slight_smile:

I use quiet mode with roller shutters and the noise is much less. Takes about twice as long to close or open. Ideal for my neighbours, when it’s early in the morning :sleeping:

I also have a hardware device of somfy where I can set quiet mode on/off, but that only works for that device. When I use the normal somfy remote it’s always in normal (fast) mode. Probably quiet mode have a special command signal.

Connexoon also have a feather (discrete/quiet mode) that can be toggled.

1 Like

Thanks for the info😉

@rvdeijk Can you use quit mode (feather) for your roller shutters when using the Homey App?
On of my Somfy IO roller shutters has this option on the hardware remote and also in the connexoon app. But not in Homey :sweat_smile:

Yes I can. Maybe you have to re-add the roller shutters and choose the right one:
Screenshot_20201021-100350_Homey

Then you will have a quiet mode flow card and there is a toggle available at the device page section:

If it doesn’t work, then contact Adrian to help you out. Probably then you have to gather a log, maybe some parameters are different.

Thanks for the info. I simply assumed it wasn’t supported…
…but I’ll try re-adding them :+1:

Update: that worked, I can now also use the quite-mode. Time to update my flows, I guess :slight_smile:

1 Like

The function has been introduced since version 1.6.6 and then some optimalisations were implemented

v1.6.13

  • io:RollerShutterWithLowSpeedManagementIOComponent:
    • Reversed quite Up/Down.
    • Added quiet mode to My position.

v1.6.11

  • Convert Up / Down commands to quiet move command for io:RollerShutterWithLowSpeedManagementIOComponent

v1.6.9

  • Fix crash when adding new Roller Shutter Quiet (io).

v1.6.7

  • Separated Roller Shutter Quiet (io) from other Roller Shutter (io) devices
  • Added action card for quiet mode.
  • Fix for Quiet Mode not working when switched off.

v1.6.6

  • Added a Quiet Mode for io:RollerShutterWithLowSpeedManagementIOComponent.

Great!! So apparently people have to re-add devices if they have quiet mode support and they have added the devices before 1.6.6.

1 Like

…and I probably added my roller shutters before the support was introduced, that makes sense.

1 Like

I have the problem with the APP that it is on Pause! Restarting Homey, nor the APP is useless. I have the error message: Timeout 3000ms.
This problem I already had, I uninstalled and reinstalled the APP. Its to solve the problem on the other hand I had to put all the blinds and skylights and adapt the flows. Its done too much work if there are any solutions!
I cannot access the APP settings!


Screenshot_20201021-125633|250x500

On the screen where you restart the app is the Create Diagnostics Report. If you tap on that I might be able to see what is causing the issue.

The code of diagnostic report

fc03586c-96e7-4ee2-bada-e7ecc19bfe38

Unfortunately it hasn’t helped. All I got was:

---- stdout ----


---- stderr ----

It is always hit and miss with that feature.
I presume the app is still paused?

Yes…

If you restart the app, does it stop very quickly?
Would you have time to get to the settings and turn on the Information log?

Yes the APP stops very quickly.

I cannot access the parameters, the page remains blank with the wheel turning. I also have the impression that the APP does not react to restart or other, it is deactivated and still on the page of the 'APP she is looking for the blinds !?

When I activate the APP its going long enough to start up, with the error message in the red bar at the top: Timeout after 3000ms

Can you remember if you had the Information log switched on before?
I have just noticed that I forgot the size check when I made some changes so it’s possible that has grown too big. If that’s what it is then I can add a fix.

Yes I know that I activate it once these problems with Somfy have started. By cons with the update I do not know if it is to stay. Moreover when I uninstall and reinstall the APP I do not know if I have activated it