[APP][Pro] Solar Panels

Yes Wifi connected, i get the error : Eroor Connect EHOSTUNREACH 192...:*
Do i need to open the gate on the SUN200 somewhere?

Can you reach it with the phone app via it’s local IP?

Hey, this is a known issue and the integration is not working for many Huawei inverters. Only specific models, using specific connection types (WiFi or ethernet) seem to work. You could try upgrading the firmware of your Smart Dongle to the latest version, and switching between WiFi and ethernet could also be the solution. If both do not work, you will have to wait until Huawei releases working firmware.

1 Like

Hi there!!

Any chance to get the RIELLO inverters added to your App?
I have a Riello PV RS 3.0 with double channel WiFi connection. I can log and monitor locally the inverter with the cell. App “RS Connect” and monitor remotely the inverter production and datas through the web portal “RS Monitoring”.
It would be great to have the Solar production integrated with Homey!!

Hi @Diederik ,
I’m looking for FVE solution and would like to choose components supported by Homey - currently SOLAX seems to be supported but it has been removed from TEST version of your app - does it mean that Solax support has been removed completely or it’s assumed that support is ensured via eg. PVOutput only ?
Thank you.

Solax should be working, but I need to port it to the new version still. I cannot yet guarantee you if it will make the cut.

When looking at inverters and future proofing your setup for smart home integration, I would not choose Solax (and many other brands) because integration relies on a cloud platform provided by them. Consider buying an inverter from SMA or Fronius, or SolarEdge/Enphase if you want panel-level optimizers. Those inverters will last a long time and can be read out locally - all of them are supported by Homey.

1 Like

Thank you for your answer, unfortunately don"t have much choice here, as companies around me don’t offer those brands… and those that does, have “waiting time 6 and more months” just to visit you to check if it’s possible to install solar panels… but I also don’t like Cloud communication, this is the reason I choose Homey Pro 3 years ago… ;-(((

The alternative is to keep the inverter disconnected from the internet, and install a smart meter in your panel that is able to communicate with Homey. I might have some suggestions depending on where you live.

1 Like

Hi all,

I’m having trouble installing my solar panels from enphase. I’m trying to add my enphase envoy (that is up in thet network and accesable in my browser), but it gives me the message that it could not find any devices. Is there a workaround, fix of do i need to do things the other way? I had it working in the past but due to dhcp instead of fixed ip it was not finding the device anymore so deleted it and now it cannot find a device again.

If i try to use the api version instead of the envoy i get an Error : [object Object]

You should not need static IPs, Homey handles discovery of the Enphase Envoy by itself through mDNS. You do need to make sure mDNS traffic from the Enphase reaches Homey. Do you have Homey and the Envoy on different subnets, by any chance?

They are on the same subnet and the acces points and enphase are in the same switch/ vlan. disabled ids/ips etc. still no devices found.

fixed!! a setting in the aruba 305 acces points was wrong wich was blocking mdns.

Hi @Diederik,

would be possible to extend your app for Solax? I have Solax and I need to control flow based on it. But currently I get only two values, which I can´t use.

https://www.solaxcloud.com/proxyApp/proxy/api/getRealtimeInfo.do?tokenId=xxx&sn=yyy

This is response:

{
"success": true,
"exception": "Query success!",
"result": {
"inverterSN": "xxx",
"sn": "yyy",
"acpower": 0,
"yieldtoday": 0,
"yieldtotal": 122.5,
"feedinpower": 0,
"feedinenergy": 3.94,
"consumeenergy": 546.64,
"feedinpowerM2": 0,
"soc": 98,
"peps1": 2762,
"peps2": 1405,
"peps3": 187,
"inverterType": "5",
"inverterStatus": "107",
"uploadTime": "2022-05-18 14:50:12",
"batPower": 207,
"powerdc1": 1646,
"powerdc2": 1371,
"powerdc3": null,
"powerdc4": null
}
}

Solax Api is here:

If it is anything I can do to help, let me know.

Thank you
Michal

1 Like

Heya!

Is this something that could be added to the app? Going to receive a Fox-ess inverter in a month or 2 so would be awesome :grin:

FYI (and I created an issue @ git)

Hi Homey’s,

The app (v4.6.3) crashes since Homey is running v7.4.x RC firmware. I use a Growatt inverter.
It all ran fine since september 2020, so it’s probably due to an Athom related change.

I’m not sure it’s the RC firmware, but I’m sure it’s occurs since v7.4.x

Does anyone recognize this?

No, runs smoothly on 7.4.2

Just for people that are interested in registering how much money your panels are producing, even with hourly changing rates (like with Tibber, FrankEnergy, etc), see the how-to here: [APP][Pro] Power by the Hour: Insights per hour, day, month and year - #637 by Gruijter

1 Like

Hello, I’ve been using this app for a few weeks now with a Huawei inverter, but a few days ago the app didn’t show the correct numbers (last update was days old).

I deleted the device and tried to put it back in, but now I have an error when I enter the ip address (it’s static) : “error: connect EHOSTUNREACH” follow by the ip adress and the port numer 502.

Also tried to install the app again, but still the same issue. Anyone got an idea what the problem might be?

I run homey v.8 0.2 and v.4.6.3 of this app. The issue appeared before I updated to Homey v.8…

You sure it’s still having the same IP?

Yes, I just checked one again in my modem.