[APP][Pro] Simple (Sys) LOG - Use this app for Simple (Sys) Logging

Are you available today for testing Henk or @Peter_Kawa .
I am first trying to solve and BLL loading issue which is a persistend pain in the behind.
After i have solved that, ill work on the Add Script, since i resetted my Hp2023 and thus can test it easy without messing up my live/production environment.

Oeh, that would be so nice, @Arie_J_Godschalk! Thx in advance!
I’d be happy to test for you, but since I am away from home today, I won’t be able to do so until after 18.00 I guess…
Keep me posted, I’ll try to test asap if you got anything ready.

Well, before i do this, i once again wanna see if i can get the memory down of SSL.
Because in Docker, the memory is okay, but on the HPs it grows when going through the logs.

1 Like

Hi @Arie_J_Godschalk ticket system works flawless now. You should find issue #18 in there

Issue with the DATE after the fix for timezone. I have added a bit more context in the ticket.


Thanks for the great app! I just open the logging and see that all ‘message’ categories are empty. Any idea what is happening here? It is in the latest stable and beta version.


Debug: fad48001-33ef-417d-ae2f-2a5960268332

Thanks for help :smiling_face::+1:

Note, it was working 5 min ago and suddenly the colom is empty. Reboot app or homey did not solve it.

Hi there,
I just updated simple log to simple sys log and now the app stopped working.
Diagnostic report: 0ad58824-c226-4a96-9b02-0f3692967097

And yes, i am using the new athom homey power adapter. 5.2v

Ill work on the issues tomorrow!


Guys, just a question, Simple log can be auto-added also to the “standard” flows, or ? I see it’s not currently in the script but I think it would be doable, or ? :wink: Eg. simple stuff like “Flow NAME executed” ?
Apologies if it’s mentioned already in the thread.

Yes, but Simple Log still had issues, it was sometimes loosing data.
I finally resolved this today and in case a file gets corrupted, it will autorepair.

There were 2 users (right now, more before) that had that issue, and after my latest update todauy, both reported that all empty lines where showing correct again.

This i wanted to solve before putting more time in it.

Also, i am fixing the Export Insight App for HP2019 and HP2023 both, and i am almost done, but now i cannot connect to my HP2019 somehow to test it.

So, i just haven’t had the time to include it into the script it yet. :slight_smile:


Thank you, as I’m running upgraded HP23 with 4GB RAM, I tried that at least for Advanced flows (I’m not user of BLL or Symple(Sys)Log till today), now I’m getting all logs into Synology Syslog - works great so far. The only thing I’m worried about is that I will be not able to edit advanced flows anymore (my advanced flows were already having issues while editing in Firefox :wink: ) , so I will be probably every-time running removal and re-added script.

Anyway, great stuff @Arie_J_Godschalk , as always ! Looking forward for standard flows, as I have around 600 of them :wink:

1 Like

Well, there is a special flowcard that is placed within flows.
The idea is that those can be configured from a part in the Simple Log app, so you can easily configure and update all flowcards from a settings screen (which will create a script, place it under the clipboard when you press the link to the ApiPlayground, kinda like i do with TEFs of Device Capabilities.

1 Like

Btw, sorry if already reported, I wonder if script could skip adding cards to those elements :

  • ANY

Unless it’s by design.

LOL, no thats not by design, the script is just really not ready yet :wink:
And right now, have spend the last few hours trying to deploy an app to my HP2019, which is connected locally, but i cannot deploy somehow.

I will get to the script :wink:

1 Like

Pfff, the AI-Mesh of my Asus AP’s switched off the Ethernet Backhaul with the latest firmware update.

Grrr, just took me a few hours to solve…

1 Like


Pff. Good to know. Turned off the auto-update function of my asus routers directly. How did you solve this?

On-topic; many thanks! The app is working perfect again! :muscle::muscle:

There is a setting:

1 Like

FYI, just tested and works fine - all Simple generated cards were successfully removed. :wink:

1 Like

That works flawless indeed, but did you try deleting flowcards from other apps, like Papertrails f.i. with the script?

Nope, never used PaperTrails. Just was updating some flows and had to clean them up, so tested this script.

I just hope even the adding script will be updated for regular flows, that would be providing finally full insights on what the flows are actually doing and when :wink:


SSL has been updated for a bugfixing: Having a Syslogclient setup might duplicate logs.