[APP][Pro] Roborock Vacuum Cleaners

Maybe. I did not look into opening ports on your Homey soo i’m not even sure if it’s possible. But IF it’s possible, it would not match the Athoms “it should work for everybody” requirement. Apps with features like that should be posted to the unofficial app store instead, soo that it’s a choice to download. I think they won’t even let me upload it, but then again… Even if they would… With almost 10.000 downloads, I think 90-95% won’t manage to do this.

But yes, I agree that I would love to have this feature. Maybe the DEV that designed the token extractor will team up and add this feature to my app, combine powers?

I think that’s a good idea.

From my understanding of the requirements, there’s nothing wrong with using a cloud service to bootstrap the setup. Ie- even if Homey doesn’t allow opening ports you can proxy these using a cloud service and send data through.
That online proxy service could then again be something that people could choose to download and run on their own webserver for more privacy. Then the Homey app could have the possibility to select from a dropdown of the default “It just works, using this cloud service” to “insert your own IP for the service here”.

This is all brainstorming and of course time consuming ideas - it’s really just to say that I personally see ways around the issue of the app doing everything internally :slight_smile:

Hi. I’m in the process of creating flows for my roborock and discovered there isn’t a card to RESUME after pausing (ie stop) the roborock. Could this please be added. I tried some other cards but it seems to make it start cleaning in lieu of resuming. I could be wrong but wanted to flag this.
ps thankyou for making a roborock app!

I’m an early adopter of the new Robrock Qrevo MaxV and I couldn’t be more satisfied with this new vacuum robot. I had an S7 before the Qrevo.

Any plans to support the new Qrevo MaxV as well?

1 Like

Hello,
My S5 Max has stopped working again. The error message generated in a flow is “Network communication is unavailable, device might be destroyed”

Any ideas what could’ve happened? Nothing has changed in the network setup that I’m aware of. S5 Max works fine within the Xiaomi app.
Homey pro 2023, WiFi, UniFi dream router and a U6 lite access point.

Sounds like a IP address change. Xiaomi app uses just internet, the Homey app a static IP.

Try finding your Roborock IP under ‘Network settings’ and compare with the IP used in Homey.

If it changed, you could try giving your Roborock a static IP in your router.

Thanks, but unfortunately that’s not it. It has the same IP as before, and it is set as static IP…

Currently the easiest way is to use Home assistant and connect it to Homey.
Home Assistant has a Roborock Integration via Roborock Account

No Token needed. Only missing the special rooms cleaning option.

But that would require needing to have a HA setup running right, can’t have it be something virtual?

I ended up here because I want to turn off the base when it’s done charging (it’s connected to a smart plug). I could do this by checking for power draw (say it drops below 5W, then shut off) but the problem is the base also drops below 5W when the robot is cleaning. By using this app it would solve that (since it would actually send the “docked” status). Another problem is that the instruction website for this app seems to be down…

1 Like

Hi! Is it possible to add the Deep and Deep+ functions for when the Roborock is in mop only mode? It’s available in the Roborock/Mi Home apps as options so I assume that it’s doable through external apps as well.

Uncertain if this is a S8 Ultra only option or what, though. But I’d like to control all these flows within Homey Pro only and get rid of the need for controls through the Xiaomi related apps.

Still no plan to rewrite this app so that it supports using the roborock android/ios app instead of the need for xioami mi home app? Like this homeassistant app GitHub - humbertogontijo/homeassistant-roborock: Roborock integration for Home Assistant. This integration uses your devices from the Roborock App