[APP][Pro] Roborock Vacuum Cleaners

Just to let others know, Roborocks works fine now, tested with S6,also with some new functionality the old Roborock app didn’t have


Anyone knows about delay?
I have the Roborock S6 MaxV and have about 20-40 sek delay on reporting to homey.
That is killing my project…
I am currently making a door under kitchen cabinet based on esp8266 L298N driver and stepper motor.
I just finished the coding, and am almost finishing the mechanism wich I will print at work…

So anyone know about this delay and maybe how to fix it?

Edit: ON/OFF works cind of all right now, but not the device status.

Really hope someone builds a new app for roborock. I don’t want to switch to Mi Home :frowning:

1 Like

You mean just install Xiaomi Mi Homey app ? The rest is the same, the functionality is even more extended, working fine since I posted update - what it’s issue ?

1 Like

Yep, switching is very easy, install the other app (don’t uninstall the roborock app and devices just yet). Now copy the token and ip from the old device to the new device you make with the new app. Test it out, see if it works, and if everything seems to be working delete the old Roborock device and app.

Where do i get that token?

If you have already installed it, it’s simply in the Roborock app setting (if I recall well, particular device setting). If you don’t have token yet at all, you have manual in the Obtain token · jghaanstra/com.xiaomi-miio Wiki · GitHub (taken from https://community.homey.app/t/app-pro-xiaomi-mi-home-app)

it’s where you put it the first time in the roborock app, I think it’s in your device settings, open your roborock device and then go to settings, and you’ll see a token and IP. You need to copy them to the new device for the Xiaomi app. Then disable the roborock app (so you can test everything), after everything works just uninstall the Roborock app and devices in Homey

Just to confirm, this applet is deprecated, and has been superseded but another app which adds additional functionality?

It still worked for me, but not on the Homey 2023, multiple people tried to contact the developer, without any reply, unfortunately. [APP][Pro] Xiaomi Mi Home App now also supports most Roborock vacuum cleaners and does work on Homey 2023.

Migration is quite easy, and during testing you can have both apps installed (just disable one to test the other)

1 Like

We still need this app. I want to be using the roborock app on my iphone, not the mii home app

I don’t think the Homey Roborock app worked with the iPhone/Android Roborock app?

That’s not what I’m talking about. If i want to have the roborock unit into HP23 now i have to start using the Mii Home app, and then i can’t have the roborock on my phone anymore. The robot can’t be connected to both

Correct, like i said, I don’t think this Roborock app (even if it was working on HP2023, could use the Roborock Token, just like the Mi Home app it used the Xiaomi token. (look at the 3rd post, it states Xiaomi token)

I have them integrated in the official Xiaomi Home app as well in HP2023 and it works fine. Anyway, then your only chance is to do sdk3 rewrite yourself

1 Like

I can’t use the camera function when using the mi home app.
Someone managed to integrate roborock with home assistant using token from roborock app, hopefully someone can do that for homey aswell :slight_smile:
(GitHub - humbertogontijo/homeassistant-roborock: Roborock integration for Home Assistant. This integration uses your devices from the Roborock App

nice, that was easy on HA. give email and you get a token. lets see how we can integrate this from HA to ghomey

1 Like


if you have the token it’s pretty easy, put in IP and token and it will work :+1: (Xiaomi token, roborock token probably doesn’t work)

What’s your point? I don’t want to have a home assistant unit running just to get this working…