[APP][Pro] Roborock Vacuum Cleaners

Welcome to the Community!

  • You obviously need to use Homey Roborock app.
  • You also need to use mobile Xiaomi app, if you missed that part.
  • You need to set static ip in your router for your vacuum, alternatively set long dhcp lease period.
  • After that you need to retrieve the token for your vaccum again. There are different ways for retrieving token and you can find them in this thread. You already find out that part but if anyone else read this I think it is good the complete routine is describe here.

If you already have everything in place it is hard to help you remotely.

Thank you for your time Morgan!!

I finally got the Roborock to connect with the Homey. I didn’t think to mix the two apps. Previously I used either the Xiaomi app or the Roborock app in both Homey and my phone. Thank you, my headache is gone for now!


1 Like

Hi Anders

Could you elaborate how you got it to work?
I’m getting the same error and I can’t figure out the process.

First I added it to the Roborock app, and then learned about the token needed for Homey.
I then added it to the Xiaomi Home app and retrieved the token.
Then I deleted the roborock from the Xiaomi app and added it to the Roborock app again.
Then I tried to use the IP and token I had just gotten, but I get the handshake error.

What am I doing wrong?

Should I add it to Homey while it’s still connected to the Xiaomi app?
Is it possible to have it connected to both the Roborock app and Homey at the same time?

Just for clarification:
On your mobile only Xiaomi Home app works.
On your Homey only Roborock app works.
No other combination!

Arh OK.
So I need to use the Xiaomi app on my phone instead of the Roborock one?
That just means I lose the camera option as I understand it, but automation is more important :slight_smile:

I’ll give it a try - thanks.

Yes, you can not use live-camera but AI avoiding obstacles still works.

I dont understand.
My Roborock has worked for a lon time.
For som weeks now it seams like it has been ofline - the IP is correct.
Trued to unninnstall.
med new innstallation
Locked IP adress - checkted for new token - the token is the same - but when innstalling:
Could not connect to device, handshake timeout.

Where shoud I start to check for sollution?

proplem solved - dont know how - but works now.

1 Like

I think sometimes it is problems on Xiaomi server side.

Yes - believe that was the problem now.
I also see that the XY coordinates has changed. Trying now to find point 0.


Right now I am using the Xiaomi Mi Home app in Homey and everything works perfect! I wanna try the Roborock app in Homey :blush: Is it safe for me without breaking something between Xiaomi Mi Home Homey and Xiaomi app iPhone? In other words have booth apps on Homey? :blush:


1 Like

Thanks Hannes :blush:

1 Like

When I add my s5 en push the test button I’ll get a time out message ?

What do I wrong

Incorrect IP or token, or different network

1 Like

Going to try it

@Justin will you als update the app to SK3?

Hi I should appreciate a little help/ideas.
I am trying to find the room IDs and I have find 4 off them, 16,17,18,19 the problem is that I can not find the 2 last of them that I have, Have tried 20,21,22,23,24 but no luck :frowning: just saying it can not find the room. Any ideas?

Have you named all rooms? If not - give them names and then try again.

In the Xiaomi app? I must have missed that it is possible to name the rooms, where do I do that? :pray::blush: