[APP][Pro] Pipup

@Remko_H if you chose the HLS (Chromecast) compatible you should stream it as a webpage. As Homey generates a webpage with a HLS player.

Most devices don’t run HLS or RTMP out of the box.

I also have not yet managed the Nest Hello as a “live stream”

Thanks I will try it :+1:t3:

1 Like

Is it possible to add a maximum height to a video URL? The width setting is working, but the height is currently 100% (maximum height of the tv screen). I’m using the ‘test’ version of the PiPup (Homey) app.

did you manage to get it working? I cannot make it work.

Sadly not, tried it a couple of times and gave up. :cry:

does anyone have pipup already working well on homey pro 2023… i can only send text messages at the moment

I have set up a special webpage to display when starting the tv in the morning.
And have set the time of the popup to 30 minutes.
But how can i close the popup on the Chromecast With Google tv?

All the buttons respond to the normal UI and not the popup.


Homey 2023 has some trouble with sending pictures.
Also other apps has this problem.
Athom is working on it

1 Like

I cannot get it to work.

I have PipUp (V1.1.1) installed on homey (early 2018 V8.1.5).
I have the nvidia shield pro (android 11) with the PipUp ap running (blue screen telling me its active on xxx.xxx.xxx.xxx:7979)

I have ran the adb code, also in settings on the shield it says overlay is enabled.

It used to work on my previous nvidia shield (not the pro)

Am I missing something here?

I had the same problem. After restarting the Shield and opening the Pipup the problem was solved.

Did anyone solved the RTSP stream issues on the Shield? I can’t get it working.

I got the tv to show tumbnails, but its only showing the same pictures everytime.
Got eufy security.

Any suggestions?


I dont know if I can ask you here a question?
I have a phillips tv with pipup on it and I am develloper on my tv so I did al the steps.
I have a foscam g4p camera and with this line http://usr:pwd%3F@
I get the message net :: error clear text not permitted.
Can you maybee point me in the right direction?
Help would be much appreciated.
If I trie https then a white screen appears.
According to foscam I should use
But that shows nothing

Greetings Igor van Vegchel


Is it possible to get this working with a Samsung the frame 2023 tv?
Or is it just easier to try and install this on the shield?

I have it working on a Samsung frame.

Did you have any guide to follow? I seem a bit lost

I installed it a while ago. Don’t know the steps anymore.

But this is something to look at; app permissions.

We’re are you stuck?

What camera do you have? Tried with my G4 dorrbell pro unifi and it does not show the picture ;( Something special to think about of the pixel width? I get the snapshot in a notification to make sure it doe work but not on the tv. Can only send text right now. On the new Homey pro 2023.

Hi all question does somebody got the app working on a Google tv Chromecast ? I have everything installed but homey doesn’t see it