[APP][Pro] Pipup


Now available in the AppStore

This app in the store is a collaboration between @Rogro82 and me.

PiPup is an application that allows displaying user-defined custom notifications on Android TV.

The most common use-case for this application is for sending notifications, from Homey, to your Android TV.

Some example scenarios:

Show a snapshot of your camera on your TV (eg on a motion trigger)
Display a notification with the video of your camera when someone is at your door
Send a notification when your dryer/washingmachine is ready
Anything else you might find useful
The application is currently in a public beta

Send notifications to your Android TV using Homey

Note: First install the application “PiPup” on your Android TV.

*Important: after installation / updating it is currently adviced to restart your TV and open the application once to make sure the background-service is running

The Android TV application is currently in a public beta

To enter the beta and install the application on your device go to:

In case of any issue with the Android application (not the Homey app!!) please post them at the correct repository:
Issues · rogro82/PiPup · GitHub.

Action cards:

And a tiny action movie

If u like this app consider buying me a beer.


This sounds exiting. I have installed the app on the TV (Sony) and it shows the server is running with the TV’s IP address and a socket number.

I have installed the Homey app and created a flow to send a PiPup message to the TV but nothing happens.
Should the address entry in the PiPup card contain just the IP address or include the socket number as well?
I have tried both but would be good to know for sure.
Any suggestions on what to try to see which end is not working?


It’s just the IPadress.
But maybe i forgot to mention an important thingie:

Important: after installation / updating it is currently adviced to restart your TV and open the application once to make sure the background-service is running

Will add that to the OP, lemme know if that works for u.

Thanks for the tip but still not working.
Maybe Sony is blocking it. I will check out the Pipup app.

Hi Adrian,
I have the same experience here.
Although I installed it on my Nvidia shield.
All went well, setup on shield.
Restarted Shield and directly started pipup.
Created flow in Homey and entered correct ip-address of Shield.
I think i setup everything completely, but with tests the Shield seems not to receive any information to show in pipup.

Sofar i can check not a single error is logged.

Are there any other suggestions that we may try?


Please also supply the version of Android TV so I can check.

I only have two sony tv’s but i will try to find someone with a Shield.

One thing you can check is if all the app permissions are correctly set. Basically on newer Android TVs (8.0+) the permission SYSTEM_ALERT_WINDOW should be set and normally the Google Play Store should automatically set this on installation because Android TV has (or perhaps had) no dialog to do so.

If someone knows how to connect to their TV using ADB then you could try:

adb shell appops set nl.rogro82.pipup SYSTEM_ALERT_WINDOW allow

so I tested the PiPup App today and it works like a charm :slight_smile:

even when I unplugged the Sony Bravia Android TV completely from power the app works fine after powering the tv on again.

Now I created a flow to show the front door camera if somebody rings the doorbell :slight_smile:

great job @Rocodamelshekima


Credits for making the app goes to @rogro82 !

ok - so thx a lot to @rogro82 :slight_smile:

1 Like

Have the same experience on my Shield, everything set up but no pip on shield. Have motion sensor in front yard, activating my IP cam installed on the same wall, test works ok, but no data on the shield! App and everything installed ok!

An update has been pushed for the Android app with a fix for a permission issue (Android 9+)
Maybe @Tangodelta or @friethoe can check again?

1 Like

I removed the prevous version and installed the latest version.
Unfortunately that did not change it.
After that I installed an app for adb support on my phone and did the adb command as described.
Now I do get a popup screen from homey on my shield, but only the texts. The expected image is not shown (yet).
I use the same tag for notifaction by email and that works so the image should be okay, but the shield does not show it.
Thanks for the great work
Gtz Eric

1 Like

I just tested it with another actioncard where i could enter a image-url and that works great.
So the app works like a charm, thanks for that.
I think the image tag is just not ready when the popup want to show it…
But thanks sofar, i love it

1 Like

Very nice!!

Strange, did the same with image url, but still just text, added an delay, 8 sec on the motion sensor, but still no change.

U also did the ADB part?

Hi Guy’s, great app!
I installen it on a Philips oled903 Android 8.
The app is running, dit not do the adb commant there is no popup comming on the tv.
Is there something I can test?



1 Like

Do you have any brief instructions on doing the ADB part?
E.g what apps to use on the TV and phone etc.

1 Like

Any plans to provide a feedback mechanism? i.e. post a question and provide an answer using the TV remote control?

I have now worked out how to do this and it has solved the issue. I am now seeing messages on my TV.

If anyone else wants some guidance (I accept no responsibility for these instructions) I found this page gave me the solution to enable adb on my TV:

I then downloaded the command line tool for the PC from:

Then I opened a command prompt on my PC, set the path location to the folder where I had extracted the tools (cd \Temp\platform-tools), then entered the command given by rogro82.
I had to accept the connection on the TV to allow my PC to connect to it.

Hope that helps anyone else that wants to try.