[App][Pro] PaperTrails Log - Advanced Logging and Log management (v0.6.3)

I have just installed Papertrails from the “homeybackup.web.app” but it crashes every time it runs. Homey says it has sent a report so hope it contains some useful information.

P.S. Backup looks good from first impressions :+1:

Hi, Thanks for trying and your msg.
Only Issue I get Crashreports if you open the Log viewer and then restart the Papertrails App… Homey doesn’t like that. (annoying, could not get it fixed and no big deal for me at that moment )
Workaround is Close the Log viewer and Start Papertrails App.
Then it should keep running
Until you restart Homey or the App and have the log viewer open.

I have it on my list and will look into a solution soon.

O, And Thanks for the compliment about Backup :wink:

I did indeed have the log viewer open as I had just pushed Papertrails to my Homey form the Backup web app and that automatically switched to the viewer.

By coincidence Homey just updated to rc-7 which made it reboot and Papertrails seems to be working now. Probably because I didn’t have the log viewer open when it rebooted.

Thanks for the prompt reply.

Every time I change the syslog settings to my syslog server ip and other syslog settings they are not saved. Always back to “default” settings and as syslog server ip address.

Homey version is 3.20

1 Like

Hi @M_a_r_c_o
Is this new or has it worked before? What version is your Papertrails app?
I just tested latest versio on a clean Homey and it works for me, when do you lose te setting? (Restart app, Restart Homey, PtP ? just waiting for… )

Can you send a Log from the App after setting the information?
Then restart the app and send a 2nd log ?

Hi @Dijker, isn’t it longer possible to send the Log with Mail when it is trunced?

I still use this with the Email sender app.


Hello @Dijker

Sorry for the delay

App version 0.6.3 currently but also before this version.
It has not worked for me (I think), I loose settings as soon as I exit the COnfiure App, no reboot of app of Homey is needed for it. I go to configure app, change IP address, go back twice, go into App configuration again and its again

Tried what you asked, and will send you the codes.
But! I removed the app from the Homey and reinstalled the app and now it seems to work properly.

1 Like

I would like to config syslog, but I am not sure how to create a rule for this? What is the log-format?

Hello @Dijker ,
Thanks for providing this functionality. Which I do not understand well enough.
My first question: I set up a papertrail account and am now looking for the app to send the logs to my papertrail account. Is that at all possible?
The reason I would like to so that is that the Papertrail website offers tools to work with the logs.
Thanks again.

Yep, set the Syslog logging from settings in Papetrails Log on Homey to the Log… and port number from your account on https://papertrailapp.com/ and start logging.

1 Like

Hello @pmeester,
Did you manage to get it working.
I configured the Papertrails app to forward to logs3.papertrailapp.com:21074 and configured https://my.papertrailapp.com with the ipaddress of my router.

But the PaperTrails Logboek “Stuur syslog regel” is not showing up.

Any ideas?

Mine works with writing a normal log line “voeg toe aan de log”.

That part is working okay.
The problem that I have is sending/writing a syslog event to https://my.papertrailapp.com/events

With the card I indicated it writes already to papertrails webapp. Have not yet used the “write to syslog” card.

Has anyone experienced the automagically adding papertrail additions to all of your flows by the website under Homey v5(rc50)?

Since it is (still) experimental firmware, I am a bit cautious. Would not want to mess up all of my flows… :slight_smile:

Dank! Het werkt goed.

Unfortunately the “Magic” setting doesn’t work any more since FW 2. I’m on RC50 and just updated all essential flows with a Log card manually. Unbelievable there is no logging provided out-of-the box by Homey! There is just too much guessing involved in troubleshooting issues right now, even with basic logging in flows. :frowning:

Maybe a bug: when using the Zone tag in the txt field between brackets ("[]", expecting something like “[Bathroom] My Sensor: 21” in the log), they end up like this:
021-01-04 13:16.31 [[[deviceZone]]] My Sensor: 10
Or should I escape these chars somehow?

For Syslog (on Synology NAS) it also seems that for a logline like: “[Flow] Started flow x”
The first word “[Flow]” disappears in the SysLog entry. I only see “Started flow x” as message but no program?

A logline like: “Room1: LightSensor= 21” shows up in Syslog as:
Room1 as Program, and “LightSensor= 21” as message. Is that expected?

And just a thought for a feature suggestion: an exclude filter. To track all device updates, I use a flow with “WHEN Any sensor 's value changed”, but this unfortunately also includes some logs from very chatty Aqara light sensors that am not particularly interested in. In this case an exclude filter would help: in the log view similar to the include filter, or in the app settings before it actually gets logged.

I understand from

that the magic still can be performed from:

That’s what I was referring to…