[APP][Pro] Netgear Router - Network control, Presence detection, Energy monitoring

Hi Fred,

Thx for registering, but you haven’t pasted the result of the compatibility test there. That is what I need to do a first analysis.

Oh, my bad! I tried again and pasted the result.


Not my day today… another try!

That is a weird issue. The test looks fine. Also the diagnostics report looks ok. Is this happening with all devices you add, or just your iPhone? Can you try the same with another device (e.g. your TV or NAS or an Android phone)?

I added my NAS, but still no parameters. It looks exactly like the screenshot of the iPhone.

Could it be related to this generic Homey problem on VLAN’s?

No, I don’t have a VLAN. There are no restrictions there.

And you are connecting both Homey and the phone to the main router, not to a sattelite?

Yes. Both to the same router. With the RBK50 it didn’t make a difference if connected to a satellite or the main router.

New development: the nas is showing parameters. Sadly enough the iPhones still nothing. I have disabled privacy and anti tracking for my home network.

If you send me a new app diagnostics report, maybe I see something now.

And I’m wondering if your iPhone is spoofing its MAC address. If it keeps changing its MAC then Homey has no way of telling it is the same phone. You could check the ‘known devices’ list in the app settings. It takes some puzzling, but when you see your iPhone multiple times with different MAC addresses, then that is the problem.

That was something I was thinking about as well. iPhone has that option to mask the Mac, but already turned that off. Also the same settings are used and did work on the RBR50.

The testlog says something about 5 errors. Could it be something regarding those 5 errors?

4 of the errors are in functions not used in the Homey app. The only function that gives an error and is used in Homey is checkNewFirmware. But even if that error occurs it should not lead to problems in the Homey app (and I did not see this error in your diagnostics log).

I returned to the RBR50 because I couldn’t get it to work sadly enough…

App doesn’t show SOAP port anymore. Can’t log in.

App worked fine untill a couple of days ago when I saw a <!> appear next to my router. Said it couldn’t log in. tried to relog many times but unsuccessfull. I have a Nighthawk RAX200.

It worked on SOAP 5000 before…

Did you try rebooting the router? If you didnt change your firmware or password then what do you think is causing it?

Firmware did update according to the logfile. Rebooting didn’t help. Made a back up of all the settings and performed a factory reset. After that reloaded my settings and it is working again…

1 Like

I just relased version v3.3.0

  • Netgear package 4.4.1.
  • Added discovery of orbilogin.com.
  • Added support for SOAP port 5555.
  • Use of TLS (https) is now default when adding a router.

Port 5555 is apparently a new port used by certain router types / firmware version. It might solve the issue of not being able to add a certain router. @Ian_Akkermans : that is you for instance. But I don’t know because you never gave feedback on my questions I asked you to help you solve your issue.

By the way: In my opinion app store reviews should be used for:

  1. Letting other potential app users know if it is worthwhile to install the app or not, and why.
  2. A way to say thanks to the developer for providing a free app that is useful to them

But I find more and more that it is used to get the developers attention to fix something for them.

To make a personal statement: I am developing apps primarily for my own use, and secondly I add features and ‘how-to’s’ so that other people can also benefit from my work. I do this for the community and in my spare time. I am motivated by people who like my app so much that they make a small donation, or by people taking the effort to thank me for my work in the forum or with a 5 star review.

Now if an app really sucks, and the support from the developer is shitty, off course you can warn other potential users by leaving a bad review. But please don’t leave a review saying ‘something isn’t working for me’, without bothering to go to the forum first to help tackle the issue. It takes a few seconds to leave a bad review. But if you want to respect all the effort the developer puts in, please also put in some effort yourself…