[APP][Pro] Netgear Router - Network control, Presence detection, Energy monitoring

But there is no condition? So what should this flow do? and there is a question mark in the first action, this should be a TAG.

Maybe if you tell us what you want to achieve, we can help you.

I have deleted the else-clause. Now everything is workig normal.
Thanks. Solution provided :slight_smile:
The else-clause has no use. I was testing en logging, so I did provide all exit-paths.

2 Likes

v3.2.5 is coming up:

  • Netgear package 4.3.3.
  • Fixed double flowcard naming issue.
  • App color changed.
  • German translation updated. (thx @fantross !)
  • German and Dutch readme added.
1 Like

I was hoping that, next to my Netgear R7800 router, it was possible to control my WiFi extenders (EX6200) as well with this app, either as router or as attached device. My goal was just a simple restart. Unfortunately no. I believe I was able to access these extenders ik the (old) Genie app, but login on port 80 fails. Just a quick reply if anyone has an idea to send a remote command on the LAN to restart these extenders once a day?

What happens when you do a compatibility test from the app settings (using the ip of the extender)

Posted the test result on GitHub. Thx for your efforts!

Hi,

Thanks for a very useful app!

However I cannot make the presence functionality work. I think it worked briefly after installing the app but not anymore. The app doesnā€™t register when connected devices comes online/offline. They just appear as online all the time. Other app functionality works fine (fx WOL)

I have tried restarting the router, restarting the app, removing and re-adding my connected devices.

Any suggestions how to fix this? THX!

What is the router poll interval? 1 minute is usually ok.
Did you pair the individual wifi devices to Homey as attached device? Check the advanced settings for timeout. If you e.g. set it at 5 minutes, the device should report as disconnected about 5-6 minutes after you turn off the wifi.

And did you take a look at the logs to see what is going on (in app settings) . If all fails please do a router compatibility check and create an app diagnostics report after that.

Hi Gruijter,

Thanks for a very quick reply!

  • Device was added as attached devices
  • Timeout is set to standard (180)

When taking a look at the log I do however, see a lot of errors. I presume they are lated to the issue, but I do not know what they mean?

Latest errors:
2021-12-30 15:45:45 [8b7eeb50-30ff-4d7d-bc0a-4ce6a350f7d4] Error: device_not_found at Remote Process { code: 404 } upload_speed 0
2021-12-30 15:45:45 [8b7eeb50-30ff-4d7d-bc0a-4ce6a350f7d4] Error: device_not_found at Remote Process { code: 404 } download_speed 0
2021-12-30 15:45:45 [8b7eeb50-30ff-4d7d-bc0a-4ce6a350f7d4] Error: device_not_found at Remote Process { code: 404 } signal_strength 88
2021-12-30 15:45:45 [8b7eeb50-30ff-4d7d-bc0a-4ce6a350f7d4] Error: device_not_found at Remote Process { code: 404 } link_speed 1201
2021-12-30 15:45:45 [8b7eeb50-30ff-4d7d-bc0a-4ce6a350f7d4] Error: device_not_found at Remote Process { code: 404 } ssid XXX
2021-12-30 15:45:45 [8b7eeb50-30ff-4d7d-bc0a-4ce6a350f7d4] Error: device_not_found at Remote Process { code: 404 } device_connected true
2021-12-30 15:45:45 [err] [ManagerDrivers] [8b7eeb50-30ff-4d7d-bc0a-4ce6a350f7d4] trigger error Error: device_not_found at Remote Process { code: 404 }
2021-12-30 15:45:45 [err] [ManagerDrivers] [8b7eeb50-30ff-4d7d-bc0a-4ce6a350f7d4] trigger error Error: device_not_found at Remote Process { code: 404 }

If I look in the activity log under the attached device it says my iPhone was last connected two days ago, even though Iā€™ve been in and out of the home several times since.

That is not a normal error. Is your Homey operating ok? Are you on a stable firmware. Maybe you need to do a ptp.

1 Like

I have a SXR80, but canā€™t add the device to Homey (DevicePoll HTTP request Failed. Stattus Code: 401)

  • Firmware version 3.3.0.122
  • Log:
    2022-01-14 11:39:58 [err] [ManagerDrivers] [netgear] [d756571f-43d7-4a35-9b5e-db3718a4a621] DevicePoll This is not a valid Netgear router
    2022-01-14 11:39:58 [netgear] [d756571f-43d7-4a35-9b5e-db3718a4a621] Logging in
    2022-01-14 11:39:10 [log] [MyApp] test ready
    2022-01-14 11:39:03 [log] [MyApp] Retrieving known devices list
    2022-01-14 11:38:58 [err] [ManagerDrivers] [netgear] [d756571f-43d7-4a35-9b5e-db3718a4a621] Error: HTTP request Failed. Status Code: 401 at NetgearRouter.getCurrentSetting (/node_modules/netgear/netgear.js:274:11) at processTicksAndRejections (internal/process/task_queues.js:97:5) at async NetgearRouter.login (/node_modules/netgear/netgear.js:194:28) at async NetgearDevice.login (/drivers/netgear/driver.js:54:4) at async NetgearDevice.updateRouterDeviceState (/drivers/netgear/device.js:315:4) at async NetgearDevice.onInit (/drivers/netgear/device.js:397:4)
    2022-01-14 11:38:58 [netgear] [d756571f-43d7-4a35-9b5e-db3718a4a621] Logging in
    2022-01-14 11:38:58 [netgear] [d756571f-43d7-4a35-9b5e-db3718a4a621] Device Access Control could not be enabled
    2022-01-14 11:38:58 [netgear] [d756571f-43d7-4a35-9b5e-db3718a4a621] Access control enable requested

-Test:
========== STARTING TEST ==========
Node version: v12.16.1
Netgear package version: 4.3.3
OS: linux 4.14.15-g3c513a6eca
Info: Homey fw:7.2.1 app: 3.2.5
t = 0
trying to auto discover Netgear routersā€¦
[{Firmware:V3.3.0.122WW,RegionTag:SXS80_WW,Region:ww,Model:SXS80,InternetConnectionStatus:Down,ParentalControlSupported:0,SOAPVersion:3.46,ReadyShareSupportedLevel:0,XCloudSupported:1,isBlankState:1,LoginMethod:2.0,orbiSupportedLevel:1,SOAP_HTTPs_Port:443,host:192.168.0.100,port:80},{Firmware:V3.3.0.122WW,RegionTag:SXS80_WW,Region:ww,Model:SXS80,InternetConnectionStatus:Down,ParentalControlSupported:0,SOAPVersion:3.46,ReadyShareSupportedLevel:0,XCloudSupported:1,isBlankState:1,LoginMethod:2.0,orbiSupportedLevel:1,SOAP_HTTPs_Port:443,host:192.168.0.101,port:80}]
t = 3.263
trying to login using method 1ā€¦
method 1 ok.
trying to login using method 2ā€¦
method 2 ok.
trying to login using auto methodā€¦
reported login method: 2
t = 4.048
trying to getInfoā€¦
{ModelName:SXR80,Description:Netgear Smart Wizard 3.0, specification 1.6 version,SerialNumber:**********,SignalStrength:2,Firmwareversion:V3.3.0.122,SmartAgentversion:3.0,FirewallVersion:net-wall 2.0,OthersoftwareVersion:N/A,Hardwareversion:N/A,Otherhardwareversion:N/A,FirstUseDate:Sunday, 30 Sep 2007 01:10:03,DeviceName:6KY2115NAC3E1,DeviceNameUserSet:false,FirmwareDLmethod:HTTPS,FirmwareLastUpdate:2022_1.12_15:48:48,FirmwareLastChecked:2022_1.14_11:43:41,DeviceMode:0,DeviceModeCapability:0;1}
t = 6.417
trying to getSystemInfoā€¦
{NewCPUUtilization:24,NewPhysicalMemory:32,NewMemoryUtilization:46,NewPhysicalFlash:128,NewAvailableFlash:60.99}
t = 15.036
trying to get supportFeaturesā€¦
{AccessControl:3.0,SpeedTest:2.0,GuestNetworkSchedule:1.0,TCAcceptance:1.0,SmartConnect:1.0,LightingLED:1.0,TimeZone:2.0,SatelliteInfo:2.0,NameNTGRDevice:1.0,AttachedDevice:2.0,MaxMonthlyTrafficLimitation:4293918720,AvsSupport:1.0,OrbiTribandSupport:1.0,DeviceTypeIcon:2.0,BackgroudSpeedtest:1.0,NewDeviceNoti:1.0,DeviceTagging:1.0,CDIL:1.0}
t = 15.116
trying to get the LAN configurationā€¦
{NewLANSubnet:255.255.255.0,NewWANLAN_Subnet_Match:1,NewLANMACAddress:94A67E6EC2FD,NewLANIP:192.168.0.1,NewDHCPEnabled:true}
t = 15.488
trying to get the WAN configurationā€¦
{NewEnable:1,NewConnectionType:Static,NewExternalIPAddress:192.168.3.120,NewSubnetMask:255.255.255.0,NewAddressingType:Static,NewDefaultGateway:192.168.3.1,NewMACAddress:94A67E6EC2FE,NewMACAddressOverride:0,NewMaxMTUSize:1468,NewDNSEnabled:1,NewDNSServers:195.130.131.4 195.130.130.4 8.8.8.8 2a02:1800:100::44:1 2a02:1800:100::44:2}
t = 15.789
trying to get the Traffic Meter Enabled Statusā€¦
Traffic Meter Enabled: true
t = 16.121
trying to get trafficMeterā€¦
{newTodayUpload:707.29,newTodayDownload:3501,newMonthUpload:10895,newMonthDownload:23396}
t = 16.489
trying to get the Traffic Meter Optionsā€¦
{newControlOption:No Limit,newNewMonthlyLimit:0,restartHour:0,restartMinute:0,restartDay:1}
t = 16.788
trying to get System Uptime (hh:mm:ss)ā€¦
3:39:04
t = 17.128
trying to get the Device configurationā€¦
{BlankState:0,NewBlockSiteEnable:0,NewBlockSiteName:0,NewTimeZone:+01:00,NewDaylightSaving:1}
t = 17.447
trying to get Parental Control Statusā€¦
404 Not Found. The requested function/page is not available
Parental Control Enabled: [object Object]
t = 18.135
trying to get Qos Statusā€¦
404 Not Found. The requested function/page is not available
Qos Enabled: [object Object]
t = 18.477
trying to get Qos Bandwidth optionsā€¦
404 Not Found. The requested function/page is not available
{}
t = 18.821
trying to get available and selected WiFi channelsā€¦
Available channels 2.4G-1: Auto,1,2,3,4,5,6,7,8,9,10,11,12,13
selected channel 2.4G-1: 1
Available channels 5.0G-1: 36,40,44,48
selected channel 5.0G-1: 48
5.0G-2 channels are not available
5.0G-2 channel is not available
t = 20.808
trying to get Smart Connect Statusā€¦
404 Not Found. The requested function/page is not available
Smart Connect Enabled: [object Object]
t = 21.498
trying to get router logsā€¦
last log: [DoS Attack: ACK Scan] from source: 52.97.212.245, port 50815, Friday, January 14, 2022 11:44:08
t = 22.074
trying to get Guest Wifi Statusā€¦
2.4G-1 Guest wifi enabled: false
5.0G-1 Guest wifi enabled: false, method: 1
5.0G-2 Guest wifi is not available
t = 23.159
trying to get Device Access Control Statusā€¦
Block Device Enabled: false
t = 23.499
trying to get attachedDevices method 1ā€¦
Number of attached devices: 29
First attached device:
{IP:192.168.0.7,Name:Samsung Living,MAC:4C:C9:5E:B3:9B:76,ConnectionType:wired,Linkspeed:1000,SignalStrength:1000,AllowOrBlock:100}
t = 27.372
trying to get attachedDevices method 2ā€¦
Number of attached devices: 29
First attached device:
{IP:192.168.0.7,Name:Samsung Living,NameUserSet:true,MAC:4C:C9:5E:B3:9B:76,ConnectionType:wired,PortNumber:2,Linkspeed:1000,SignalStrength:100,AllowOrBlock:Allow,Schedule:false,DeviceType:35,DeviceTypeUserSet:false,DeviceModel:Samsung,DeviceModelUserSet:false,Upload:0,Download:0,QosPriority:4,Grouping:0,SchedulePeriod:0,ConnAPMAC:94:A6:7E:6E:C2:FD,DeviceOS:Tizen,DeviceTypeV2:5,DeviceTypeNameV2:TV}
t = 34.915
trying to check newFirmwareā€¦
check newFirmware method: 2
{currentVersion:V3.3.0.122,newVersion:,releaseNote:}
t = 35.26
trying to logoutā€¦
{host:192.168.0.1,port:80,tls:false,username:admin,password:*****,timeout:18000,sessionId:A7D88AE69687E58D9A00,cookie:true,loggedIn:false,configStarted:true,soapVersion:3,loginMethod:2,getAttachedDevicesMethod:2,checkNewFirmwareMethod:2,guestWifiMethod:{get50_1:1},lastResponse:ā€¦,queue:{queue:{},overheat:1642127635622,pending:true,params:{default:{rule:common,key:common},rules:{common:{rate:3,limit:1,priority:1}},overall:{rate:10,limit:1},retryTime:2,ignoreOverallOverheat:true},heatPart:100}}
t = 35.343
test finished with 4 errors

there is something weird with the test. It runs most of the tests good. In fact it runs all the required tests needed for the Homey app. But the test is run on the router with IP 192.168.0.1, while the discovery finds two other IP addresses: 192.168.0.100 and 192.168.0.101. Did you add the correct IP address when pairing in Homey? I think you need 192.168.0.1 with port 80.

I have in total 3 orbi devices:
192.168.0.1: this is my main router
The other 2 devices (192.168.0.100 & 101) are both satellites ( WiFi 6 mesh system)
When I press the discovery button the app finds 192.168.0.100

The router I added in Homey is the .1
On the same device I ran also the test.

Interesting. What happens when you go from a browser to: Router Login & Setup | NETGEAR
Can you post the result here?

And what If you go to http://routerlogin.net/

This app realy works well! Thanks Robin! Is it possible to find or store somewhere the data from the internet test? I would like to use it this way;

IF last test download speeld is lower then 50mb/s
AND phone xxx is offline
Then restart netgear router

1 Like

:smiling_face_with_three_hearts:

Sure. It is available as flow token. See this example: Shared Flow | Homey

@Ian_Akkermans any feedback on this?

Hi Gruijter,
I have been a very satisfied user of your app for which I thank you. Recently I bought the Orbi RBK353 and am running into some problems. So the app detects the RBR350 and is able to show how many devices are connected. But when I add my phone as a separate device it doesnā€™t give me any parameters and most importantly it does not register if it is connected yes or no. I use it as an awareness signal to let my homey know if I am home or not. I have also have a RBK50 and that worked fineā€¦ Both routers are set in AP mode. Hope you have a suggestion how to make it work.

Grt
Fred

Just to clarifyā€¦ both routers are not active at the same time. The RBK353 (WIFI6) is a replacement for the RBK50 (WIFI5)

Nice you have good use for my app :blush:

To solve this issue start by doing a compatibility test from the app settings, and post the result on github as an issue (the copy button takes you to the right spot)

You need a free Github account for that.

Done! Itā€™s registered under fred737.
Thx