[APP][Pro] MELCloud & MELCloud Extension - Take control of your heat pump

@Heszi, can you screenshot the value for target_temperature.flow_cool at https://tools.developer.homey.app/tools/devices ?

Also I invite you to join https://slack.athom.com/ to ease debug discussion.


yes, I experience this also

Fix still pending on Homey side.

Sure, here you find everything:

Ok it’s related to both a MELCloud issue and Homey regression: MELCloud value for cool flow target temperature is under the minimum authorized (5) and then Homey set null instead of minimum.

This behavior should have been fixed with the latest Homey firmware, can you make sure in settings that you have the last one.

Another radical but efficient solution should be to remove and recreate your device because the last version of the app includes a fix but which can apply only at device creation.

I have the latest Homey version how I know:
I will try to recreate the device

Ok recreate is solved the problem, heat pump available again, thank you for the fast response and help @OlivierZal :slight_smile:

You’re welcome, I’m glad your issue is solved :blush:

I’m getting the following error in my flow:

operation_mode_zone_with_cool InvalidTypeError: undefined is undefined but expected string (invalid_type)

Previously this was working correct for a long time. Has anything changed?

I’m on the latest firmware 10.0.9 and Melcloud 33.0.1

What can I do without recreating the device?

Hi @Peter_Schrijver, this is fixed in the upcoming release, which is available in test: MELCloud | Homey

Can you confirm it fixes the issue?


1 Like

@Yankie, @ArnarS, to be sure the % fan power bug is from Homey mobile app and not from the MELCloud app, you can check if the values are good in the web app: https://my.homey.app/

I’m in touch with Athom developers, still pending on their side, don’t hesitate to raise a ticket in addition to my actions.

@OlivierZal, it is for sure a Homey mobile (android) app issue. I have same issue with my Elko (thermostats), as I’m using them as regulators. The index on the slider is always zero when opening the regulator and the scale goes to 10000%. It is difficult to get a screenshot of it as the index disapear too fast after removing my finger from the slider.
Everything is normal in the web app. I will also raise a ticket to Homey support.

@OlivierZal, came an update on my android Homey app today and the issue with the slider is fixed. Showing 0-100 % now.

1 Like

Hi Guys,

Since yesterday my AC units are not controllable even from official iOS melcloud app. I checked wifi, power cycled the complete airco system.

Is there some ongoing cloud issue?

(Good advice: Keep batteries in the IR controller just in case)

Same here, since last night, so must be a cloud issue on Mitsubishi’s side

Yes, MELCloud servers seem to be down (you can see that even the official MELCloud mobile and web apps don’t work, and that there is no Wi-Fi displayed in Settings > Wi-Fi strength).

This is what you can now see in the official application (the year was wrong by 20 years))): Dear MELCloud client, from Wednesday, April 17, 2004, voice assistant integration and application connection
MELCloud does not work properly in some cases. Our software development team is working to resolve this issue and we are confident that service will be restored soon. We apologize for any inconvenience caused and thank those users who contacted us to let us know.

Anyone have new info when melcloud is going to be fixed?

Unfortunately no…

1 Like