[APP][Pro] Global Caché - Connect IR, Serial, and Relay to Almost Any Network

It looks like they should be compatible from a quick look at the api specs so I’ve added the models to the ITach WF / SL drivers. Could you try by installing the latest master from github?

See: [HOW TO] CLI install method

Source: https://github.com/plarsson/com.globalcache


I’ve added a duration setting to the relay command now. Please try it out by manually install latest from master:


Sorry couldn’t for the life of me figure out the CLI install method :frowning_face:

But I have since upgraded to v 2.0 and can’t iTach devices to Homey. Are you planning on updating it to work with v2? (sure hope so)


1 Like

Hi yes, I’ll update it to work with 2.0 soon. The plan is to make use of athom Web API so we can edit the config using the browser.


That is great news, sir! Ready to test!

Hi, can you please me help with string for command? I want sent command as in picture.

in iTest string *Z01ON is OK

I try any combinations:

        { "name": "on0", "value": "*Z01ON" },
        { "name": "on1", "value": "*Z01ON\u000D\u000A" },
        { "name": "on2", "value": "\u002A*Z01ON\u000D" },
        { "name": "on3", "value": "\u002A\u002AZ01ON\u000D" },
        { "name": "on4", "value": "\u002A\u002AZ01ON" },
        { "name": "on5", "value": "\u002A\u002A\u005A\u0030\u0031\u004F\u004E" },
        { "name": "on6", "value": "\u002A\u002A\u005A\u0030\u0031\u004F\u004E\u000D" },
        { "name": "on7", "value": "*Z01ON0D" },

Thx for your help

Hi all,

I’m trying to get my iTach Flex working through @pln’s Global Cache App. The published app doesn’t seem to support the iTach Flex but the code on the GitHub Repo is slightly more up-to-date. I’ve packaged it and installed it using the CLI and it finds my Flex (the published one doesn’t as the identifier isn’t supported).
The problem is I can’t figure out how to use it, I’ve added some Pronto codes in to the settings (changed in the source code before publishing as copy and paste isn’t working RN) but I can’t figure out how to send them. There’s nothing in the device when I click on it, and if I add it to a flow I get a page that asks me to select a relay command and then search for an iTach Connector (I don’t know what that is). I was expecting to see the device I added to the settings page in here.

I’m sure I’m being stupid, but can someone tell me exactly how please?

Thanks, Siobhan.

Hi all,
I tested the Bluestack (https://www.bluestacks.com/) to run the Homey-app in Windows! It works just fine to copy, paste Pronto codes!!

Hi all,

I am using an ITACH IP2CC. WIth version 1.1.0, I notices=d some changes using the “send relay command”.
What is the “number” field for?

Ow i see that the web app is not showing the correct info. On the Homey App it says “delay milliseconds”. Is this a correct parameter for the IP2CC? I can’t find any reference in the ITACH API? Also the ITACH IP2CC is not changing the relay with this version.

I tested with ITEST and that is still working.

Ignore my previous message if you saw it.

Looking at the code, the duration field looks like it allows you to invert the state of the device after a delay of x. So if you send a close and a duration of 1000. After 1 second it will re-open again. Sending nothing or zero should have no effect.

This change was made a while ago but not picked up until my changes for the UI and iTach Flex went live.

Unfortunately it is not working for my IP2CC. if II set the “duration in milliseconds” to “0” or “100000” msec. Can you please have a look at this.

Unfortunately I don’t have one of these devices to test with. I’m just working on what the code says it does instead of being able to test it.

IP2CC should work fine now with the latest version 1.1.2. Please try it out!

Cannot fogure out how the app works (read all thread) Not a programmer. I have used iTach and Global Cache with iRule before but now switched to homey.

Where do I enter the commands/IR codes som I can create flows for IR?

I have only installed the app. Do I also have to do a CLI install or should the app be all I need in order to set it up? Homey have found my devices and they are installed, but now I am stuck.

Hi Elo,

You enter the hex codes on the app configuration page. You will create devices and commands which you can use directly in your flows. I can for example reuse the flow and the pwr command of my living room projector on the “backup” projector. (Both Epson and same series)

Works great. Thanks.

1 Like

Hi! Struggling with the Homey App. Sending Literal command to GC iTach IP2SL, but I only gets the reply “Client is not defined”
Everything is working great with iTest, sending command “Power On” and have tried to input \u at beginning of command. Any Ideas?

I have the exact same issue/ error. I’d hook up an IP2IR to make it work by infrared.
Tried to contact the developer but no response yet.

Just a quick question if someone already tried or could try to possibly modify “app manifest”? Would it work with CLI install on new HB2023?

Still got that problem? Which fw version your Homey is running on?