[APP][Pro] ELKO Smart

Help! I have many Elko Super Thermostats and they work fine, but I have some working as Regulators and they won’t turn on or off by Flows. I have Excluded and Included without any help. This is to my bathroom and it’s now 15 degrees, so I’m a bit desperate. Anyone?

I don’t have a solution, but can confirm I’m having the same issue, turning on and off my thermostat set as regulator in a flow don’t work anymore. Seems to coincide with the latest stable update.

I think so too

The issue with “measure_temperature” were fine between 17. february and 25th. See graph.
This one is set to “supervisor_floor”.
Might be a quickfix?? @prj_84 :smiley:

I’m also experiencing this issue:

Invalid setting type! Got string but expected boolean (checkbox) for regulator Mode

For me it happens when I try to turn on chold lock as my son now can reach the on/off button :see_no_evil:

Since the latest update my Elko-devices won’t work with my homey pro. I have lighting (elko smart dim puck uni), hating thermostats (esh plus super tr rf ph) and Elko smart switches to control the lighting. I have many Phillips hue devices also but they seem to work fine. In the homey app the icons of Elko Smart products show that the homey is searching for connection but can’t find any. When navigate to the menu for adding Elko devices in the homey app the same “searching symbol” shows in the top right corner and I’m unable to add new devices. Does anyone know a fix?


I am not getting any kWh. Just installed this smart thermostat and it’s been using 600W for a while.




There is an issue with Elko Super Thermostats and Fows after the latest Firmware update. The Flows cant turn the thermostats on/off when they are in regulator mode. The issue causes a lot of trouble and is well known in several forums. I tried to check if there is any beta versions of the app but ELKO Smart App for Homey | Homey just redirects me to the oridnary version. Is there some way this can be solved ?

It seems to not work directly out of the box, at least I can’t get it to work.

Everyone thought that the latest firmware was the issue that caused the flow not to be able to turn on/off the Elko Super thermostats. When talking to support they mentioned that the firmware update could not cause the problem, but the Elko app was updated the day after, so there must be a bug in the lastest app version. Can this please be corrected? It is causing a lot of heating problems in my hose.

Hei. Jeg sliter med store utfall på mine zigbee enheter. Har nylig endre hele huset til Elko smart. Kommer der støtte for Elko hub. Så jeg kan koble alle enheter til huben, og styre huben via homey.

If you could please keep the conversation in English as much as possible, then more people will be able to participate and help you. If you would rather not or can’t communicate in English then please check out Non-English boards/categories:

Norsk (Norwegian)

I’m having problems peogrammigng the smart Pir. How do i get the light to stay on for 15 mintes?