[APP][Pro] ELKO Smart (deprecated)

Please discuss the New Official App in the correct Topic: [APP] ELKO Smart - Smart, right?

Adds support for Elko Smart to the Athom Homey



    • Known bugs:
      • forced_timeouts when multiple commands are sent from Homey app or Web app
      • New ESH316GLED devices produced after June 2019 should not be affected of this bug
  • ESH Super TR RF PH - Thermostat

    • Read floor and air temp
    • Read/Write Thermostat set temp (if thermostat mode)
    • Read/Write Regulator % (if regulator mode)
    • Read Heating status
    • Read Child lock status
    • Read Temperature Mode (Floor, Air, Floor Guard)
    • Advanced settings:
      • Set heating cable effect (watt) to get correct kw/h readiuts
      • Set max floor temp when used as floor guard
      • Time between on/off on relay
      • Temperature calibration
  • ESH 316 Dimmer Remote (BETA)

    • Toggle and Dim up/down through flow cards
      • Issues - Flooding of commands! Use carefully or your Homey will be unresponsive!
    • Thanks to Niels Petter Rasch-Olsen on this! (SDK2)
    • Rebuilt driver for SDK3. * battery devices has a problem when binding to attributes. Several restarts corrects the issue. Working on a fix.

Supports new Elko Smart range. Support for battery devices will follow.

  • battery devices has a problem when binding to attributes. Several restarts corrects the issue. Working on a fix.

If you like the app, please donate so I can keep improving it!




  • Power measure
  • power reading
  • new capabilities


  • New capabilities on Thermostat.
  • Introduced beta support for ESH316REMOTE RF PF"


  • Regulator mode on thermostat
  • Settings to set heating cable effect to get correct Watt and kw/h reading
  • Reading of some new attributes.
  • Added support for ESH Dimmer remote.
  • Rebuilt dimmer driver to again try to fix forced_timouts. (will be 100% fixed with new zigbee core)
  • Worked on app for future release.


  • Bug fixes
  • Added mode to reset kw/h


  • Reset mode under Maintenance menu for correct capabilities in the device tile.
  • Reading some new attributes (Frost, Night (can not be set before new zigbee Core)).
  • Worked on app for future release.


  • Rebuilt to SDK3
  • Changed name of app to Elko Smart since this is the new name of the product line.
  • Cleaned up and removed unused and unsetable attributes for Super Thermostat.
  • Some changes i flow cards for Dimmer remote
  • Added support for several new Elko Smart devices


  • Minor bug fixes


  • Fixed issues with new dim devices

To be updated

I use the thermostat in regulator mode. Is it possible to add flow?

I will look into this in later release :slight_smile: Thsnks for feedback!

Will the ELKO app be updated to support the coming Homey v5 ?
Your ELKO app was the reason i bought a Homey in the first place to be able to control my ELKO ESH dimmers :slight_smile:

Allready ready! Just waiting for 5.0

You can fins the version in test untill release :slight_smile:


I presume then it is not backwards compatible but need version 5.0 to work, right?

After the last beta update to r38 one of my Elko thermostats failed to initialize. When I restarted the app, another one failed. Then I restarted the app again, and guess what: Another one failed… Now I have 3 devices not working. All other zigbee is working fine (ikea and hue). And in developer.athom.com all nodes are online. Did something change in r38 that the Elko app didn’t like?

Not directly related to the app but interesting for solving timeout issues that can occur with the ELKO Dimmer. Has anyone successfully updated the firmware of the Dimmer?
I’ve tried with the software from here:
Without success. First tried a micro SDHC card and then realized it should be micro SD card. Ordered one but still no success…
EDIT: Realized that the linked file likely is only for the dimmer remote. Found some other files on this forum: https://www.hjemmeautomasjon.no/forums/topic/1121-er-elko-zigbee-åpen/?page=8&tab=comments#comment-41561
Now need to figure out if I dare to test them. I cannot see even when I interview the device in homey developer -> Zigbee what version is currently installed.

Hi! It has to do with zigbee firmware that do not respond to Homey when receiving a command. Without this command Homey get a forced_timeout. So I’m affraid a update will not fix it. With the 5.0 Homey software it is possible to do s fix for this. But I want someone to test the original driver first. (I do not have the old dimmers anymore, just new with new zigbee chip)

Yes, you have to update to get new devices.

Hi! I run newest software both in my tedt enviroment and production. Tried to redtart several times, but all works fine. Do you still have the same problem?

I now upgraded to V5.0 RC38 and the 1.0.2 experimental version of the app. It works a lot better but still pushing it there will be timeouts. Do I understand right that it is a new physical chip in the new dimmers so updating the zigbee firmware of the dimmer will not help? The firmware update files I got seem to be version 0.0.20 and 0.9.36 One should be for zigbee and one for the dimmer itself. Issue is I do not know what version I am currently on Homey does not seem to fetch that so maybe it is an upgrade maybe it is a downgrade.

I have problems yes… I tried to pair one of the thermostats that wasn’t working and it paired up right away. So the units are good and they show up in developer.athom.com as online so it’s a weird bug. It should be a button for retry connection in zigbee or something :stuck_out_tongue_winking_eye: I’ve also tried rebooting homey without any luck.

Update: I left the Homey without power for 1 minute and guess what. After the reboot everything is working again! Another mystery solved by turning it off and on again :heart:

1 Like

Homey 5.0.0-rc38 with ELKO Smart 1.0.2.

ESH Super TR Thermostat RF, firmware 1.2.5R.

When I try to pair my thermostat to Homey (add device) and follows the instructions for which buttons to press, it says “Radio pairing” in the display for a few seconds, and then nothing happens in the Homey app. I also tried pairing as a generic Zigbee device, but same issue…

I have two thermostats, and same issue with both.

I also tried to move the Homey right next to one of the thermostats, so it’s not a range issue.

Any hints on where to look?

1 Like

To answer myself (and possibly others with the same problem): I changed the channel from 18 to 15 at https://developer.athom.com/tools/zigbee , and magically, I was able to add my thermostats.

Hi, great to see support for the new Elko devices as well!

What is the consensus on what is the best dimmer between 316GLED RF and SmartDim Vri for those who have tried both? Any difference in what data can be extracted, what can be controlled, stability, etc.?

I got a reply from Elko stating that the firmware of the 316GLED RF is not Zigbee 3.0 certified yet, but that the radio chip should be capable of it (assuming that means post june 2019 hardware). Besides the possible lack of smart features, the 316GLED should be the better dimmer from what I can tell, for LED at least.

Quality wise I would go for the 316GLED. Yes it misses some smart features, but is rock solid. The only dimmer working with my LED spots.

On SmartDim Vri all parameters can be set in advanced settings in the software (Dim% when turned on, Max/min dim etc.) But that has to be set manually on the device on 316GLED. But again, you do this only once. So I would say go for the best quality choose 316GLED.

Hi, I see from the info on this app that it supports “ESH 316GLED Dimmer RF PF” and “ESH Super TR Thermostat RF”. Looking into outfitting my house under construction with ELKO smart and using Homey as the hub. Can anyone tell me if the App/Homey also support the “SMARTDIM VRI UNI” and the " SMARTBRYTER 10A" las one being a regular switch without dimming?