[APP][Pro] D-Link Z-wave App

Getting my sirene tomorrow and available to test. Is this the latest version or is there a version for cli install?

@Ricky_H This is the latest version: https://homey.app/sv-se/app/com.dlink/D-Link/test/
If you experience issues, please create a crash/diag report and I will have a look at it.

1 Like

Got the sirene and tested immediately. Created a diag report because while it works. When using different sounds, as a quick test fire alarm and Door chime, give the same “Sirene” sound.

Thanks for testing and reporting @Ricky_H. I will look into this.

1 Like

I can also test manual install versions if needed for a “quicker” testing.

Just tried version 0.0.7 on my Siren - DCH-Z510 as for people above it only gives one sound and not the door chime.

a3b9f14a-745d-417b-b46f-e3ea70ab74b7

Hi Johan, I’ve tried adding the motion sensor but to no avail. I’m not sure what I’m doing wrong but Homey can’t even detect/include the sensor. The app instruction is to press the button inside the cover but I’m not clear what button as there is the tamper key and the flushed reset buttons. I tried putting the sensor into inclusion mode based on the usual d-link manual (led is flashing red) but homey can’t detect the sensor.

Hi!

I come from homee and have several d-link smoke detedtors in my Z-Wave network. Would be great to get them functional (smoke / manipulation detected / batteries)

Device Model/Name: DCH-Z310
Manufacturer ID: 264
Product Type ID: 2
Product ID: 30

Regards,
Matthias

Hi, sorry for the late reply.
If you are unable to add the device as a generic Z-wave device the fault is not in the app but with the device or Homey. If you are able to add the device as a generic Z-wave device but not as a device supported but this app please reply with the device information you get when adding it as a generic device.

Hi @commy, thanks for your request. I added the device to my todo list.

Dear Johan,

I try to connect the D-link sirene to Homey. But he isn’t connecting. When i select the sirene in the app, I first get this screen:

And in less then a second het switch to this screen and then nothing happens

I don’t use a Hub or any other divices from D-link.

Do you know what to do?

Hi, sorry for the late response.

Try adding it as a generic z-wave device. If you are unable to do so it’s a generic Homey issue and not with the app. Please let me know if you are able).

1 Like

Hi Johan,

I returned the siren, because i didn’t get it to work and already found another option that works better for me. Tnx anyway for the response

Hello Mr Johan Bendz

One of my colleagues has been in possession of the Homey Bridge for a few days. I recommended the Homey Bridge to him, but I only realised afterwards that not all existing Homey Pro Apps are compatible with the Bridge.

Will you be adapting the D-Link app for the Homey Bridge, or is that a bigger undertaking?

Thanks in advance for your efforts!

Regards
Stefan

Any news about making that siren be more then a siren :wink:

Hi @StefanA, sorry to say the D-Link app is not planned to be released for the Bridge any time soon. Not only my decision when and if it will get there as I need to have Athom’s approval to release it. But I will give the app some love and update it so it is ready for the cloud if it gets accepted.

1 Like

Hello Johan Bendz

Thank you very much for the quick reply! I will pass on the answer accordingly.

Since the Homey Bridge doesn’t quite promise what was touted in the keynote, I can imagine that many potential Homey users will turn away from Homey.

It’s a great pity, because in my opinion the Homey Pro is one of the most comprehensive complete systems on the market.

However, since the potential customer is told, “we have noticed that Homey Pro is too expensive, so we are now offering you a cheaper, cloud-based solution”, it would have been obligatory to mention what limitations this solution entails.

This is of course not a criticism of you. Thank you again for the quick response!

Hi again.
I can only agree, Athom have received quite some negative feedback on this.

Hi Johan!

Did you try to finish the smoke detector DCH-Z310? I have afew of them and are migrating from Tellstick.

I can confirm same as commy

zw_manufacturer_id 264
zw_product_type_id 2
zw_product_id 30

I would be overjoyed if it was possible to get the D-Link DCH-S16 into the homey! :star_struck:
Thank you in advance!