Homey Community Forum

[APP][Pro&Cloud] Shelly

It seems like (after checking in the code) you have multiplied the kWh value with 0.000017. But now it is way to small.
After my own calculations with my 2 plus 1pm devices it should be multiplied with 0.001.

Just to show how I calculated:
One lamp that draw 8,7W was on for 16 hour this night.

Correct value:
8.7x16x0.001=0.1392kwh

The value in the app shows:
8.7x16x0.000017=0.0023664

Just wanted to let you know what I found :slightly_smiling_face:

Is MQTT through Homey still working with the shelly app? I think it is not working for a while, but had no time to investigate what was going on.
When I check MQTT.fx I see no topics from the shelly devices I have.
Klikaanklikuit is still working through MQTT.

According to the Shelly documentation the total is measured in watt-hour. See Switch | Shelly Technical Documentation . But I have a Shelly plus device somewhere myself and will verify.

MQTT is supported by the devices myself, you do not need my app for this. Check the MQTT settings in the webinterface or through the Shelly app.

v3.4.11 - 2021-11-14

  • Fix for incorrect calculation meter power capability on Shelly Plus devices.
3 Likes

Updated yesterday, couldnt connect to shelly. So i restored and disabled updating…

Anyone else had problems?

I use a node-red dashboard to switch and dim the lights.
And I setup MQTT by the devices itself. When I give commands in MQTT.fx it works.
But I cannot manage to get it too work in Node-Red Dashboard. It works different than from Homey.
And when I switch on MQTT, I loose cloud support.
Before it worked fine through Homey.

You were so fast with your fix i didn’t even have time to complain or rate you down.

I value you and your quick fix

Hello, it‘s not possible to integrate the shelly 2.5 into homey beta (with bridge). If i tap on the link in the homey app, sign in and then nothing happens.

It looks like it is frozen…

Try opening the link in the browser or try pairing through the web interface of Homey.

1 Like

Hi i have a Shelly 4pm. Any one knows why is the temperature so high? It seems that the temperature displayed by Homey is in Fahrenheit. Is it possible to change it to Celsius? How please. Thank you

Thanks a lot, with the web interface it works. But i had to open the link in a new tab. Thank you very much for your fast help.

Nope, this is the device temperature in Celcius. It’s a little high indeed but not too absurdly high for a device like this.

And to note; it is not the environment temperature it’s the device temperature.

hello @Phuturist. Thank you for your work! I’m newbie, I’m approaching with my new homey bridge but I have some problem with roller: I have 7 shelly 2.5 but I’m unable to set as roller. I have the same problem of #2080. the only way that I have to add the shelly 2.5 is as Relay (see attachment). I tried to pair with an android smartphone, a iPAD, via web browser but nothing. shelly firmware are update. shelly app version is v.3.4.11. Can you help me?



Roller shutters are not supported by Shelly Cloud and thus not available in the cloud version of Homey app for Shelly devices.

(maybe a dumb question but) homey bridge can help me?

What do you mean? Homey bridge connects to Shelly cloud, and if it’s not support by Shelly cloud, homey bridge cannot support it. Maybe your question would be if Homey Pro supports it?

No, only with a Homey Pro.

I mean connect the shelly 2.5 directly to homey bridge, bypassing shelly cloud

I’m reflecting on your answer but i can’t understand it (my ignorance surely): rollers are supported by shelly cloud. I can control the rollers from the shelly app. The problem, as I understand it, is that homey’s app “doesn’t see” that a roller is connected to a shelly 2.5. The “lack” is Homey app, or am I wrong? if so, is there a possibility that in the near future this thing is “fixed” ???