Shelly plus 1 PM not available in Homey

Dear Shelly development team, I have recently purchased a new Shelly plus 1PM switch which is unfortunately not listed as a supported device in your app. I can only find the older model there. Would you be so kind to add this device to your Shelly app for Homey, so I can start using my new device? Thank you in advance for your effort.

There is an “official” Shelly thread. It’ better to request new devices in this thread, because then it’s centralised and maybe other user requested this device already and get a respond from the developer:

In the future please use the search function or have a look at the bottom in the app store first.

I assume you are using Homey Cloud. You can probably pair it as a Shelly 1. I’ll update the name in the next release.


I used shelly 1 now but paring didnt work.
Got an error.

The device can be found in the shelly integrator.

Do you have a tip?

Error: Not Found: PairSession with ID c9c8d516-48aa-45f9-b896-27e2bb5ca349


Kind regards,


Try pairing trough the web app:

Hi @Phuturist, I’m in the same situation as the topic creator. I tried your tip, adding my shelly plus devices via the homey web app, but get the below error:

Error: A Webhook with ID homey:app:cloud.shelly:xxxxxxxxxxxx already exists.
    at Remote Process

in the homey iOS app (add devices), all available shelly units show a loading spinner in the upper right and are not clickable. Don’t know what to do, but really want to start adding more shelly devices to my home.
Any further tips or a release date of the new version including the shelly plus for homey cloud (beta)?

As mentioned the Shelly Plus 1 is supported using the Shelly 1 driver. I just pushed an update to fix the name but the functionality is already there. The error you are seeying is totally different then the one discussed earlier and I have no clue what to make of it. I’ll ask around if other developers know where this comes from.

Ok, some news on this issue. I deleted my “homey” account in the iOS app and setup a new one with my beta key. After that, the shelly app could be installed in the homey web app and the shelly integrator page found the device. I enabled both options, saved and quit the shelly integrator page. Now, my shelly plus 1 shows up in my homey app (IOS and web app), but i can’t trigger it.

I can trigger the light (the shelly is connected to a ceiling lamp) via wall switch or alexa, but not via homey. No errors.

Did i forget something?

You did not enable the cloud on the device?

Cloud is active. :thinking:In addition, I can control the Shellys via Alexa, which also happens via the cloud. I also have a hue bulb, which works fine with homey.

Sorry. Therefore in advance, at the risk that the problem is a user error or something with homey itself: Thanks for your help!

I did notice an issue with syncing device status for GEN2/Plus devices connected to cloud. I just pushed a new release to fix that. But being able to control a GEN2/Plus device connected to the cloud is working in my test.

Hey, I updatet the shelly homey app, deleted the shelly plus and re-added it. Now i can control it via the homey app. Great it works now! Really appreciate your support!!!

Do you think this is something with the homey beta? I would like to buy several shellys for lights, dimmer, rollo shutters and some senors and now i am a bit afraid of having this kind of trouble with all new devices.

It was probably an issue with my app which I fixed. Not all Shelly devices are supported over Homey Cloud yet and it’s still a bit uncertain if the integration with Shelly cloud devices and Homey Cloud will continue to work. So i can’t really give you a proper answer.