[APP][Pro] ChargeAmps

And I’ll reply to myself…
Took a few minutes before the API key was active but after that I get connection with the Dawn and can see some information.

I don’t have all the features like 220V and Groundlight on the Dawn, but I bet the charing information will show up. Now it’s just to try and charge and see if the information is updated.

1 Like

Good news!!

If Charging works and data is updated it means that I can more or less do a “light” copy of the HALO device and remove 220V control and Groundlight and by that be able to create a dedicated Dawn device.

Please keep me updated on your testing! Highly appreciated!

Hello. I’ve gotten the API-key, and followed instructions. Still I get the error according to my attached file.
What can I’ve done wrong?


You were right.
I used my admin e-mail instead of my user e-mail.

Thank you for outstanding support with quick replys!
And great job with the app! :slight_smile:

This could be caused by two things as far as I can see:

Either your API key hasn’t been activated yet (normally is done when they send out the API key but have heard of others who had issues).

The other and more likely problem is that there is an error/mistake in the email/password/APIkey that you have entered in the settings.

@DS_is_me Did you find a solution to the problem?


How did your test go? Did the device get charging data populated?

You were right.
I used my admin e-mail instead of my user e-mail.

Thank you for outstanding support with quick replys!
And great job with the app! :slight_smile:

Sorry but I have not been able to test it yet since I have no access to a chargeable car and my motorcycle is already in a suitable SOC to be stored through the winter. Let’s see if the winter will subdue and I can burn of some charge on the bike… :slight_smile:

It will most likely be a Tesla Model Y sleeping in my garage early next year, so I will report back as soon as I have charged any of the vehicles.

After I installed the device in homey it seems that the rfid settings changes to “locked” after a while. I want it always “unlocked”.

Thanks for the report, the RFID settings are not implemented in this App so far and should always be unlocked. In fact the only thing the current code does in regards of RFID is to set it to ‘false’ (unlocked) when changing current and switching on/off the charger:

// Set Current and ChargerMode
  async setChargerSettings(userCurrent, userMode) {
  try {
    this.log(`Setting charger settings in ChargeAmps with current limit: ${userCurrent} and mode: ${userMode}`);
    await this.api().put(`/chargepoints/${this.chargeAmpsId}/connectors/1/settings`, {
      chargePointId: this.chargeAmpsId,
      maxCurrent: userCurrent, // Set the max current from the parameter
      rfidLock: false,
      mode: userMode, // Set the mode from the parameter
      cableLock: false,
    }, {
      headers: {
        Authorization: `Bearer ${this.chargeAmpsToken}`,
  } catch (error) {
    this.log("Axios error:", error);

Are you also using this with some other implementations such as Tibber? Have myself seen that Tibbers implementation of this locks the RFID. My guess is that there are something other that you also use to control/manage the ChargeAmps device that causes what you see with the RFID.

There is nothing in the current code that locks the RFID

Thank you a lot for developing the app! Helps me control my HALO along with the lowest energy prices and replacing tibber.
One issue I got that my car (e-Golf) keeps on draining power after stopping charging (about 130 W), which I command through the Volkswagen app. Apparentely, the HALO doesn’t want to deactivate as long as there is an ongoing power consumption. According to charge amps customer support that could bypassed using charging schedules. However, using static schedules would destroy the idea of charging during lowest hours.
Do you see possibilities to modify charging schedules through the API and Homey app?

Hello Sebastian,

Thanks for your comment, happy to hear that you have usage of my app.

Regarding your issue with your car continuing to draw power from the charger even if the charging is completed. Need to understad a bit more about your issue first, is it so that when this happens it does not matter if you turn the charger off manually in my app in Homey or in ChargeAmps iPhone/Android App? The charger will still remain on as long as the car continues to draw power from it?

Regarding accessing Scheduling through the API, it could probably be done. At least I think the schedule is accessible through the API. But even if it is… this will be rather challenging to get into my App, but will definitely explore the options.

as much as I understand does the e-Golf continue to keep the onbord electronics after the charging is being deactivated in the Volkswagen app (doesn’t matter if it is done in the app itself or via the Homey integration). This results in the 130 W power consumption which in turn leads to that the HALO doesn’t want to deactivate.

So basically, I set up my Flow in the way that I activate first HALO and then the charger of the car via the Homey VW interface. When battery at 80% (or any other preset value) I stop charging and a bit later I tried to deactivate the HALO. Which is not working due to the awkward function from ChargeAmps to not let to deactivate the HALO whilst there is a power consumption. Hence (and what i tried first), it is also not possible to only activate and deactivate HALO and let the car always activate charging as soon as there is power.

From ChargeAmps customer service I got now the hint that deactivating under active power consumption works actually with the schedules. Which I tried and worked.
In parallel, I keep also discussing with them if it is possible to change HALOs behavior but I presume to get an update there might be more complex whilst it would actually kill the root problem. Maybe you could also test how your HALO behaves. This invitation also to anybody else here.


Thanks for all the details, think I understand what you are saying. Will try and see if I can reproduce your problem, but not sure I can…

In the beginning of building this app I did have some problems that in the backlight of things was more related to the different Flows I used to test with. What I saw then was that the charging started as expected from a Flow, but then I had an Flow that turned the Halo Charger Off and that stoped the charging and the Charging Port in my HALO was turned off even if the car was charging. In the interface of the Car App it said that the charging had been interrupted.

Currently I have problem to start to implement Schedule function in my App because I am currently trying to build support for other ChargeAmps devices than the HALO, if things work out the App will shortly be renamed to ChargeAmps and have support for HALO and DAWN devices.

New version released!
Version 2.0 and name changed to ChargeAmps (Previously named ChargeAmps HALO).

News in this release:

  • Name change of App from ChargeAmps HALO to ChargeAmps
  • Support for the DAWN device

The support for the DAWN device has been developed completely without any testing as I don’t have access to the model. But basic functionality should work as it uses similar API commands as the HALO device.

Hej Borgen,
apparentely our friends from ChargeAmps did update now their app / webinterface in order to fix the issue that the charger can not be turned off whilst the car is charging. You may see that after uppdating the app. What happened though is that they introduced a new button. According to the developer from CA I’m in contact with should this be even reflected in the API.
Are you able to check this out and eventually mirror the function to the Homey app? That would be great and essentially resolve the issues.


Thanks for the update. What Charge Amps App version are you running and on what model of phone?

I have version 1.25.1 on my iPhone, that app version is now three weeks old and I don’t see any new button in that App.

Have looked through the Charge Amps Swagger (API tool) and as far as I can see there have not been any changes there yet.

If your contact at CA could clarify what have changed in the API it can most likely be implemented in my Homey App.

Got Android 1.17.1 but it is also visible in the web interface:

Let me contact the guy there again.

Strange… I don’t have it in my web interface. Could be a coming feature that is enabled on your account as a test?

Interesting. i got now to know that the API should host the following codes for the start / stop: