[APP][Pro] Beacon - Detect your presence with BLE beacons

Can you send a log?
Goto: /manager/settings/#homey:manager:apps
Click one time inside the white frame with: Apps installed on Homey
Hover the app: beacon with the “alt” key and wait until the Send to developer button appear and click on it.

I’ll have a look if there is something wrong or in conflict.

okiedokie, done. Thanks again.

Cannot find any strange behaviour. Are you certain that you have selected the device that is your beacon? I’ve you select for example a headphone ble device that device will not move out of range that often.

What beacon do you use?

I’m using two Tile Pro’s.

I tried to re-added them again. And i noticed a few things.

At first it did not see the Tiles. So i removed the battery. After waiting a few sec. i put the batteries back again. And then they pop-up in the APP. So i added them everything seems to be oke. It shows “in range”. When a remove the batteries is show “out range” after a few seconds. So i though everything was working like i should.

Then i put the the tiles away (still in house). So after 10 min. i checked it again and they where “out of range”. I got them in the same range as where i added. So i removed the batteries again and waited a few secs before i put it back. Then the Homey showed in range again.

So it could be 2 things:

  1. The Tile is not sending out the signal anymore (or the Homey is not picking it up). Don’t think it’s the first one because all the time the Tile APP says the Tile is in range. I also have a ibeacon scanner on my phone and there i see the Tile also in range.

  2. The APP is not resetting the in range and out range the right away.

If you need anymore info …just ask.

The app is only switching inside/outside if the state is changed. Can you try without removing batteries?

You are right. Shall do some more testing in real life.

I am using a Tile mate. I noticed when i make a flow with ‘Beacon inside range’ of ‘Beacon outside range’ it works perfect.
However the flow ‘Beacon change’ doesn’t work. Is this a know problem?

Homey version 1.5.13
Beacon version v1.0.14

I tried this with my Chipolo Classic and it does work but only for a little while. It will switch to “detected = no” after a while. I have to click on the Chipolo for it to be found again until the next time Homey lose track of it. I tried to remove it from the app on the phone and also reset it with the same result.

To my surprise your beacon app found my Xiaomi Mi Band 3 as well so I added it for fun and it works great! I’ve been using it for a couple of days and Homey finds it as soon as I step into my apartment.


Looks like the Chipolo Classic will shut down the discovery after some time. The Itag has the same strategy to save energy.

I’ve just verify the issue and make adjustments. I try to test it asap when i have some time free.

1 Like

Hi, just bought 2 tile pro. After few minutes they are not detected anymore.
I have to push the button, before they are detected again. (which defeates the use of them)
Is this something that can be changed in the tile pro?


Are you also using the Tileapp?

Solved it by first registering 2 tiles in tile app, and after that uninstalling app.
Now they are visible all the time.


First of all, the app seems great (still testing). Thanks for that!

I was wondering if it would be possible to still use a ble device used with beacon for locating keys via GPS and other stuff, via homey? (maybe in a later version.?)

Thx again.

That would be a different app, this one is only used for presence.

The trigger cards: The beacon is changed and A beacon is changed didn’t work as aspect indeed. Thanks for submitting a issue in github!

I’ve resolved this issue in 1.0.15 that is currently in alpha release.

I actually solved it yesterday. I added the Chipolo in the Chipolo app and the uninstalled the app and then added it with your app and it’s been working perfectly for 12+ hours now.

Best presence detection ever! Great app!

1 Like

Thank you. Works very good.

1 Like

I’ve just published to the store:

v1.0.16 - 06.12.2018

  • add BLE permission into manifest