[APP][Pro] Amazon - Alexa

FYI no disconnects since updated app. Fingers crossed. Cheers

Thanks @DarrenJ I appreciate the update. I don’t have the disconnect issues others have so it can be a bit of a black box.

Sorry just discovered another disconnect

With the test version, I have no difference.
I can only add devices if I go North America (I am here in Hungary), but okay. Otherwise connection timeout and does not find the wall swtiches under “smart plug”, it finds only my 3 Alexa Shows.

I added the switches, clicked the one room’s where I am sitting… nothing happens… and after 1 minute, it switched up. Okay, I clicked again, sitting here for 5 minutes and it is still on.
So it is still not usable for me :frowning: (after 2 more minutes it switched off itself, but in Homey dashboard it shows ON)

Did you see this?

It looks like we’re not the only ones suffering from this problem.

tldr: the HomeBridge dev came up with a fix to a ‘429’ error by sending a blank user agent, but there are subsequent reports of the ‘rate exceeded response’ error we’re seeing. They’re suggesting Amazon has intentionally or unintentionally poisoned the API.

Maybe randomising the user agent or adopting something user-specific as part of the UA? Just guessing.

@Andy_Henderson thank you thats a really great thread with some information ill im hopefull after having a quick look that ill release a fix tonight.

Looks like amazon are specifically targeting apps like mine to stop them, if that is the case this may become a game of wack-a-mole and amazon has a lot more resources than me and my hour of spare time each week.

Best of luck!

FWIW I’m an advocate of Hanlon’s razor: “Never attribute to malice that which is adequately explained by stupidity.”

Andy

The app is working fine. @HS64 problem sounds like the one I have from time to time with not beeing able to log into any of the Amazon servers. That is an Amazon problem and I solved it by trying over several days and suddenly all OK

A new version has been released which fixes the smart device connections!

I have submitted it to be reviewed by Athom and it will roll out automatically.

Just out of interest, what was your fix for this?

Hello, thanks for you app.
I want to buy an Echo Spot 2024, is you app support it ?

Thanks

@staeff when making a request I send through certain headers, for example when you visit ANY website, the sever is sent (in the header) information such as what web “browser” your using. Its called an agent header, I was sending through this information when I made requests on the their old apps API end point, but amazon had started blocking any request using my agent.

So I changed the request header, the issue is never the the ‘code’ that needs to change - I changed a single word … its figuring out whats going on and this app is not a very high priority for me, I really don’t have much spare time. @Andy_Henderson doing the leg work and finding others having the same issue was really the key that fixed this, I just read the thread and applied it to my code. My one device which is connected directly to alexa (a diffuser) started working again.


@Pierre_V - No, I dont own that device

If you want I may can help you to integrate it

Thanks for the explanation, I didn’t need it as dumbed down :smiley: I was interested if you did set the UserAgent to be empty/some other fixed value or if you now use some randomly generated string as one of the replies in the mentioned github issue was suggesting?

I absolutely get that you have better things to do in your life then to maintain this app, but exactly because of this I was wondering why you do not make it open source? I’m sure you are a good guy but still being able to verify the code would also give me a better feeling when entering my Amazon credentials somewhere :wink:

And that shows how we as homey app developers need support by the community of these apps. Contribute in these ways, provide usefull testing results and help figure out what happens in certain use cases is very valuable

1 Like

All code and apps are reviewed by Athom for that reason.

Regarding security my advice would be if you don’t feel comfortable then don’t do it.

As to why it doesn’t have an open source licence - that’s because a private repo, so as far as I’m aware it can’t use an open source licence.

As to why it doesn’t have an open source licence - that’s because a private repo, so as far as I’m aware it can’t use an open source licence.

My suggestion was less to what license you should choose (though homebridge-alexa-smarthome and alexa-remote2 both use MIT for example). Please be as restrictive as you want in relation how people are allowed to (re)use your code. But making the code/repository public and allowing people to contribute can potentially allow you to free up more of your time and help the community to add support for their unsupported devices.

I just installed, finally I could choose EU server with success, and it seems to work as well.
Thank you!

Hi,

Unfortunately, I am not able to integrate my Echo. After I log in to my Amazon account, I always get this error message, regardless of the device.

Am I doing something wrong, what could it be, especially when I read that other users (previous post) don’t seem to have any problems…

Thanks :slight_smile: