[APP][Pro] Amazon - Alexa

Hi @Jamie, quite frequently Alexa lost the ability to execute orders given by homey (especially the trigger “Alexa says” that is the one I use the most. In general it was enough to order several restart per day of the app, and this issue was under control. However starting from last week homey doesn’t not command alexa at all, even after restart of the app (he does not change alexa volume, or the trigger alexa say doesn’t work). I didn’t not tested the other triggers but I believe that it is the same for all. Thanks in advance for your support.

1 Like

Recently I started having problems. I can’t add lights anymore really.
First I couldn’t connect at all to the server but reinstalled the app, now echo devices can be added, but the lights etc don’t work anymore. I get a timeout

You mean that alexa can’t control homey devices or you can not control alexa from homey. Since the first problem has been partially solved by ATHOM. If this is still a issue for you, contact ATHOM support. With reference to the sec8nd problem, started in a so crytical way, with the first issue, they told me to ask support to ALEXA app creators.That should be JAMIE.

@Jamie, it seems that the sistematic problem over last week, was about the not correct server. Someone suggested to move to USA server, that would not have effected anyhing. By the way, now it works.

thanks anyhow

Same here. I’m located in Belgium. Everything works fine but finding the routines.

Only other problem I have is when I go to “configure app” in app settings and disconnect/reconnect to the app, the alexa devices do not react to any command from homey anymore. Deleting and re-adding the divices do not work, neither does restarting the app. I have to uninstall and reinstall the app to get it to work again each time I do this. This is no big deal for me, but I’ve been trying anything to get the routines to work.

Should you see a loading symbol or anything when you search for the routine, since time out was increased in the last update? It seems to never search for anything. It always instantly shows “No results” after selecting “Name of the routine”.

Sorry but with the italian keyboard in phone Is difficult edit a big message without errors in english.
The point was:
In the Amazon alexa app (not Homey) all homey device are in errors but they work when “called”
My italian friend Say that problem was partially resolved from Athom, and he told me ti contact Athom because i have alredy this problem , thanks Andrea!

How can i contact Athom support ?

In the “Welcome to the forum!” post there are different ways listet how to contact Athom.


Good news everyone, Amazon have I implanted “custom commands” as routines you can now have a routine that does anything you can ask Alexa

As far as I am aware only available on US accounts at the moment


Correct, EU servers don’t have this option yet, hopefully soon

Ok. So Last weeks I’ve been messing around and have some extra info on this issue.
First of all, the devices I connect trough the app are the Sonos Beam and the Sonos One.

If I install the app and log in with my Amazon account before I add a device, any devices I add later on are not responsive. I can add the devices, but no commands seem to work in any way. Neither can I find any routines.

If I uninstall the app and then add a device prompting me to login to my amazon account, the device is responsive to all commands. But I still can’t find any routines.
The workaround I have found, and I have been able to recreate this fix, is to restart the app after installing the device. Now I can find the routines.

However, after a few days, the devices became unresponsive and restarting the app did not work.
A bit later I needed to relogin into my amazon account trough the app settings and here I encounter the same problem again that the devices are unresponsive, untill I uninstall the app and reinstall the devices, flows, etc.

Bonjour à tous,

610 / 5000

Résultats de traduction

Good morning all, for some time, all my Homey devices recognized by Alexa appear with the notation “The device does not respond” which does not alter the voice control on or off control except for all that is thermostats, thermometers or control of temperatures. I can no longer adjust the temperatures of my thermostats. I tried disabling the Homey skill in Alexa and re-enabling it but the result is the same. other devices like Smart Life do not have this problem. Thank you for help if anyone has encountered this problem before. Thank you

1 Like


That would be a problem with the Athom Alexa Skill, and you should contact support.

This thread is for the app I created, which allows you to control your Echo devices from homey.

Hi @Jamie, thanks again for your app :grinning:
I noticed a stranger things: if I create an alexa routine where I change the sound volume so as to use this as a trigger for my alexa device in Homey, nothing happens. But if I change the volume manually from my device Alexa, the change volume works as well as a trigger.
Can you help me please to make it work?
My goal is to know which Alexa is listening the command.

I have the same problems with my Sonos One.

@Jamie, is there a possibility to solve the problems with Sonos speaker?

@Jamie Hi would it be possible to add the new echo 4 etc? Also i use some meross devices. The plugs will be shown but not the Meross WiFi Switch. Thanks
Br Martin

1 Like

why the application does not find all the equipment present in alexa, will this be possible one day?


Every device is different and requires many developers many weeks to create an alexa skill, attempting to replicate their work for the 20,000 devices would not be possible.


I have many disconnections from the app (several times a day on a server), forced to reconnect my account for it to work again. Is there a solution to this?

thank you

Seems to happen sometimes, never had multiple times a day so far, which Amazon server are you on?

I can’t seem to get my devices to connect anymore. I have tried restarting the app and restarting Homey. After logging in they come back online for a few seconds and then off again.
I’ve tried different servers but same result.