[APP] Fakro

True. I also suggested them to ask the community for help. Maybe someone with development knowledge can create the update for way less.

See my latest update in the bottom of this post:

I’ve emailed

1 Like

hey guys!
I have received word from the Fakro app developers that the new app has been submitted for approval by Athom. Probably within a few days we’ll have our updated app!

Any idea what they updated?

Curious what they updated since the developer they had a few months ago had no clue what he was actually working on.

The implemented support for more (and older) devices. For example, my ‘chain motor’ and curtain that should have been working already (b/c they were the same models as listed in the app description) were apparently of an older generation.
So I have good hopes. Fingers crossed though!

Yeah, that part I get and would be nice, but things like feedback about device status are (at least to me) pretty important and that he couldn’t fix before. But well, I’ll let them surprise me. :slight_smile:

That can be found here:

It seems you’ll need to install the test version (add /test to the appstore url):

So, sadly after all this time, still no support for Windows FTP-V Z-Wave Window, FTU-V Z-Wave or their supplied ZWP10 remote, or ZWG3 wall switch for blinds and window as secondary controllers.

What are your experiences with the latest app? In my case, nothing seems to have changed. Roof window opener is still added as Simple Z-Wave Device. Disappointing…!

hi all!
I have been emailing with the developer. He said that the list of devices that he received from Fakro is missing quite a few device versions. So it’s to be expected that some devices are still added as a ‘Simple Z-wave Device’.
However, the good news is: he is really proactive and quite willing to add these missing devices to the app.

I suggest that we make a short list of missing devices here together. Let’s do it like this:

  1. first make sure you’ve installed the latest version of the Fakro app.
  2. Then try to add your Fakro device. If it ends up being added as simple z-wave device, then go to your devices in the Homey app and find the newly added device.
  3. Press and hold the device and go to ‘Settings wheel’ >> ‘Advanced settings’ >> scroll down to "Z-wave device information’.
  4. Make a screenshot of it and post it here in this thread and tag/mention me. I will then send an email to the app developer with all missing devices so he can add them.

So, that was quite a journey… All my Fakro devices (that worked before) were offline with the new app. So, I had to move Homey to all the rooms with Fakro products again. One hour per room since the Z-Wave network had to be rebuild after losing power. Anyway, all are connected again. Including the right feedback from the device (many thanks!). This had been missing with the old app.

Some issues, that I have already sent to Fakro (sorry, but in Dutch);

  • Feedback over posities werkt goed, ook wanneer je de remote (ZWR12) als secundair gebruikt
  • De instellingen bij met name de screens (ARZ) is mij nog steeds onduidelijk. Een hoop opties, maar wat doen ze en wat heb ik er aan?
  • Ik kon voorheen de snelheid van het dakraam instellen. Dat is niet meer mogelijk en nu heb ik een snel en een langzaam openend en sluitend dakraam. :slight_smile: Kan dat weer toegevoegd worden?
  • Bij screens en gordijnen is het gebruik van het percentage in flows wat onlogisch. 100% is open en 0% is dicht. Dat zou omgekeerd moeten zijn.
  • De producten reageren pas na een paar seconden op een commando. Dat is voor flows niet zo erg, maar als je iets bedient met een knop (bijv. aan de muur, zoals hier) dan wel. Dan denk je dat het product niet reageert en druk je nogmaals. Dit resulteert in foute commando’s. Ik weet niet of dit met polling te maken heeft, maar wellicht het ontvangen van commando’s realtime laten gebeuren.

Good work, developer!

I tried adding a window using the window opener now labelled “Electric Skylight” in the app v2.4.0.

When it added, the app it declared it ARZ instead, with this under advanced settings:

There two control options in app:

  • a full and closed window blind slider: when I slide towards open the window opens. If attempt to stop it half way by setting the slider half way, it continues opening until fully open. I can only close it when fully open, by sliding the other way

  • a set of 3 buttons (up, down and stop, like the physical remote control except the stop button on the control is square, whereas the app version all the buttons are round): Pressing up starts opening the window. Pressing stop, doesn’t stop it continuing to open. Sometimes tapping down stops it, after 1 tap. Other times it doesn’t. Same for operations in reverse: sometimes a single tap on Up stops the window closing, sometimes it starts opening it again.

The opening and closing is slower than the normal speed. I tried changing the setting in the app for motor speed from 2 to 3 or 4 as it indicates these are available, but it produced this error:

So it is misidentified and doesn’t work properly, but maybe instead of using the app controls, I can use flows to operate. The actions I can see in available in the flows are

  • when the state has change (Up, Down or Idle) - I’m not sure of Up means fully up/open or moving in that direction.

  • position changed: this appears to be a percentage open or closed

It seems I can get a flow to open or close it but not to stop it anywhere in between (It does not seem to respond in time).

Finally, I tried to follow @Martijn_C 's suggestion here in this thread to use the existing remote as a second controller. However the instructions for adding as a secondary controller refer to first pressing the include button on another [Fakro] primary controller. So I tried using Homey to adding a generic z-wave device, and then using the include button on the Fakro remote, which produced only this:

So, @JonE if the developer seems to respond only to you, I would appreciate his/her attention to these issues, so maybe one day he/she will make it work properly with chain controllers with windows that have it pre-installed, such as FTP-V Z-Wave Window, FTU-V Z-Wave Window, and make the app work with the ZWP10 remotes that come with these windows (and Fakro wall remotes, like ZWG3 wall switch).

About the secundary controller; all I did was adding the products to Homey, and then use the ZWS12 to add them to a group. I didn’t have to press anything on Homey. I can still control them via Homey and the remote.

Thanks - would you mind explaining the detail/exactly the steps you did to achieve this, please?

The manual for my controller says:

That’s only for the ZWS12 I guess. See the manual for that remote. There it is explained.

You mean by ‘Adding the products to Homey’ the dakraamopener or curtain ?
And how did you use the ZWS12 to add them to a group?
Did you also add the ZWS12 to Homey?
Perhaps you can explain the steps one for one? That would be really helpful!

I experienced the same issues (devices being mixed up and lagginess in the control of both the raamopener and the curtain) when testing the latest Fakro app yesterday.
I have sent my and also @K_S 's experiences to the developer. He’s quite responsive so I hope and expect to receive feedback from him soon.

I’m sorry. My mistake. I meant the ZRH12 remote. I added all the Fakro window products to Homey and after that you can add them also to the ZRH12 remote. How is described in the manual: https://www.fakro.nl/att/COMMON/offer/servis/user_manuals/FAKRO_ZRH12_afstandsbediening_gebruiksaanwijzing.pdf