[APP] Dashboard controller

Seems like this one with height 100% is the problem :thinking:

Hi, I don’t know if it’s an android problem or this app. When I put in flow start appliacation com.netatmo.netatmo everything works, but I just can’t use flow to go back to the dashboard. I tried show dashboard but nothing happens. Has anyone solved this?

The “show dashboard” card should work.
What if you open an other app temporary, before the 'show dashboard" card?

I’ve got a list of apps that show and don’t show using the ‘start application’ card (android 7.1)

[quote=“Peter_Kawa, post:52, topic:35761”]
Not showing:

  • Calculator: com.android.calculator2 (No)
  • Calendar: com.android.calendar (No)
  • Show Desktop: com.android.launcher3 (No) ór com.android.systemui (No)

Showing:

  • Chromium: org.chromium.chrome (YES)
  • Camera: com.android.camera2 (YES)
  • Fotoo: com.bo.fotoo (YES)
  • Spotify: com.spotify.music (YES)
  • Gallery: com.android.gallery3d (YES)
  • Files: com.android.documentsui (YES)
  • Settings: com.android.settings (YES)
    [/quote

It might be a problem with the Android Go edition. Because if I have Kiosk running, the show dashboard works (homeydash.com), but if I use flow to launch another app, it shows up, but I can’t go back using flow. The only thing that works is to manually tap the back arrow on the tablet and I’m back in the dashboard.

I do it directly, I analysed the FullyKioskAPI and use it directly, saves me an app on the Homey as well:

#Show doorbird on dashboard
http://192.168.XX.YYY:2323/?cmd=startApplication&package=com.doorbird.doorbird&password=******

#Back to Dashboard
http://192.168.XX.YYY:2323/?cmd=toForeground&password=*******

1 Like

I meant to say, it might be netatmo app related somehow.
So to return to the dash,
if you first start, say, com.android.gallery3d, and then a few secs later “show dashboard”
Maybe it works

As mentioned before the ‘Show Dashboard’ action card should resolves this. This basically instructs Fully Kioskbrowser to show the browser on the foreground and to load the default URL.

If this does not work, it might be a bug in the Fully Kiosk browser itself and maybe you can ask them for additional support.

Yeah I haven’t tested it with dashboard which are positioned in portrait landscape. So the used CSS will definitely mess it up.

Could you write a specific Github issue so that when I got the time I can fix it. Thank you for mentioning it.

Just for everyone’s information, these API calls are also used within the application. For info see:

1 Like

Hi, I’m struggling with what flow to create so that if I launch Spotify, it will launch the Spotify app on the dashboard. Spotify doesn’t offer any when tab, only then… how did you solve this please?

Hi @Miroslav_Gluch Try the THEN “start application” card.
Enter com.spotify.music
(or if it doesn’t work: search for the exact Spotify app ID with the android app “package name viewer 2.0” from the ggle store).

yes I understand that, but I don’t know how to create a WHEN card - WHEN Spotify is playing… If there is some way, for example, via API or similar.
For example, with MagicMirror if I start Spotify on any device, it shows me the currently playing song
https://github.com/raywo/MMM-NowPlayingOnSpotify

Hi.
Seems like “Show image on device” stopped working after the last update. Just for me? :blush:

Hi, thanks for the feedback. I’ll definitely look into it. Could you also make a proper issue for this so I can keep better track of it. Thanks!

https://github.com/rkokkelk/nl.xseth.dashboardctrl/issues


I get a error

Maybe enable wifi first?

Looks like a missing code conversion from Sdk 2 to 3 (Homey.(…) => this.homey.(…) for the translations.
@rkokkelk could check this.

Yeah you’re correct. I’ve fixed it with the just the released version.

@Bono_van_der_Pasch just wait till Homey updates the app and it should be working. Any other issues please let me know.

1 Like

Hi,

Since yesterday I get this popup shown below on all my Android dashboards when it should show an image from one of the cameras, and it is the same for Onvif and Eufy cameras.

And after that this popup

Is it just me, or does someone know what to do?

Dashboard controller v0.3.2, updated yesterday
Homey v8.01

Thanks in advance!

I’m getting it aswell. Hopefully just a bug :blush:

Sorry guys, so unfortunately I accidentally committed some debug code for an upcoming fix for an issue to the main branch and thus it was released in the latest 0.3.2 version. I’ve just released a new version what should fix this in 0.3.3.

1 Like

Thanks, that was a quick fix!
Now it works again. :slight_smile: