[APP][Cloud & Pro] Somfy Tahoma & Connexoon (v4.0.37, test v4.0.75)

In the new version I have added an option to the settings of each device to reverse the directions.

The confusion is that Homey uses up / down but Tahoma uses open / close. For window covers up is open and down is closed. But for awnings it seems up is closed and down is open.

There is a new test version https://homey.app/a/com.somfy.tahoma/test/
This fixes a potential issue with flows failing when the access token expires.
It also has option for each type of cover to change the direction of up / down versus open / close. The settings are available in each device by clicking on the cog in the top right corner, select Advanced Settings and toggle the option as required.
The setting for Invert Up / Down changes the direction of the Up / Stop / Down buttons (and the Up / Down flow cards).
The setting for Invert Position changes the direction of the slider and the 0 to 100% value of the flow cards.

1 Like

Hi Adrian. Will test it, because after a day the scenarios do not work again and got the “unhandled rejection” bug.

hi Adrian. thanks for the update and great that there is new development. It did, however, ensure that when it rains, the sun blinds are open instead of closed. but that i resolved it. I have a question about the icons. these respond when you press them briefly. that is beautiful! only one icon is disabled and the other active. while in both cases the shading is closed.

Could you send me the Device Log (Apps - Somfy Tahoma & Connexoon - Configure App - Device Log tab) while the shades are in this state.
Also let me know if you have set any of the Invert options.

Hi Adrian,

Thanks for developing this.
I have an error 401 when trying to log in. The credentials are correct. I also changed the password to see if that would fix it.
Using a homey and a connexoon io box. The connexoon works with my shutters.

I have a report from another user with the same issue but they have a Tahoma hub.

Could you login to your account on the Internet (so you can see your shutters) and let me know what the URL is in the address bar. I just want to confirm the first section so remove the end, from where it shows your user name. It should be something like https://www.tahomalink.com/enduser-mobile-web/enduserAPI

I have a suspicion that Somfy might have changed it for new accounts or different regions.


I have the same errorcode. Just received my connexoon today. The weird thing is that when i added the connexoon to my googlespeaker,it worked.

@Adrian_Rockall thank you for all your efforts and time

I think connexoon doesn’t have the ability to control the shutters through a website. Only tahoma have that ability.

Ah, OK.
Do you have a connexoon or Tahoma?

Connexoon, but I have no issues logging in. But I haven’t logged out for a while. Now I’m afraid to do so :smile:

I no what you mean :grin:.

However, the app has to log in every time the access token expires. I don’t know exactly how long the token lasts but I think it is about 10 hours.

It certainly logs in every time the app starts and when I’m working on it that can be several times an hour.

I have a connexoon io (received yesterday, so its still searching a bit). I found no way to use a website that finds my shutters, and on the tahomasite i cant login with my account.

I have published a test version in the Homey Community Store (2.0.4) https://store.homey.community/app/com.somfy.tahoma
I am waiting for the current test version (2.0.3) in the Athom store to be moved to stable, so I’m not able to publish it to there yet.
This version has an option in the app configuration to select alternative server address. This might help with the connexoon users that are having issues logging in.
I have reorganised the log in procedure, to allow for the server change over, which also stops the app form retrying bad credentials that might be locking out the account for this app. I think I locked out my account while testing with bad credentials as I had to wait for about an hour before my good credentials would work again.


Thanks for your efforts and time you’ve put into this. I tried all 3 twice(first alternatve, then connexoon rts and afterthat default) but received “error authentication failed” every time.

I tried to send you the errorlog, but received also an error

I will keep searching for an answer.

Just out of interest, do you have any extended characters in your username or password?
If so could you try a password that just has 0 to 9, a to Z, - and _ in it. It’s a long shot but I’m trying to think of anything that would be different from one that works.

The error message when you send the log suggests a DNS error as it has tried to use the loop back address. I’m not sure if that is related to the other problem as I have seen that before in another app. That seems to be related to installing from the HCS.

I’m afraid my username and password are already build up like you sugest

I have posted version 2.0.5 in the community store. I have implemented the OAuth login method in this version as it seems Somfy might have switched over to that for new Connexoon accounts.
The option can be turned on in the app configuration screen where you find a check box just underneath the server selection.
I recommend starting off with the default server and the new OAuth ticked. Fingers crossed.
Now I need to get a couple of hours sleep before work :slight_smile:

1 Like

Great work Adrian. I didnt receive an error this time. Ill try to play a bit with the app/my shutters and let you know howvit goes.

Any way to give you a coffee/beer for your efforts/time?

Sorry for the late reply, my workshift started when you posted your comment :yum:.

1 Like

Thanks for your effort Adrian.
with 2.05 I can enter the credentials, and it says login succesfull.
But when I add a new device (somfy shutter io) I get the message login failed, after it searches for devices.
I used default connection url, new oauth on and off.