Anyone managed to link to Somfy Situo 1 IO blinds?

I’m trying to connect our terrace blinds (Somfy), they come with the Somfy RF remote control: Situo 1 io Pure II.

In Homey, the only Somfy apps available are Somfy RTS or Tahoma, which I’ve tried but didn’t get any connection with the blinds.

Here’s a pict of the remote, simple 3 button remote (up / stop / down).

Somfy provide a gateway to link the IO device with the Internet, but 200EUR is overkill for only controlling the blinds!

Forgot to say, I’ve tried using the RF recording function in Homey (in both 433 and 868MHz) to no avail. No signal recorded, even being next to the Homey base. Anyone got this to work actually??

Did you try to pair your device with the Somfy rts app, by pushing the small button on the back of your remote. If it didn’t work, delete the app, restart Homey, install the app again and retry. It does work.

Hi Marcel,
thanks for the reply.
I’ve tried what you proposed but no sign of control from Homey.

  1. removed the Somfy RTS app
  2. restarted Homey
  3. Installed the Somfy RTS app
  4. put the remote into Program mode
  5. select Up/Down only, next
  6. the app shows the 3 buttons but no interaction with the blinds :frowning:

Do you have a similar setup?

Strange so your somfy screen has been added as device but doesn’t respond. Could you try to make a flow, like WHEN this flow is started, Then open screen and push the test button

If the blinds are IO, which you seem to suggest from the controller name, then the RTS app will not work.
RTS is on 433 MHz and IO is scans three radio frequencies between 868 and 870 MHz, and automatically chooses the best one to transmit the command. Also IO is a licenced encrypted protocol so Homey will not understand the signals.
So unfortunately, the only solution is to use a Somfy Tahoma, Connexoon or Switch hub.

This link takes you to a Somfy pdf that explains the IO protocol:

That didn’t work either. I’ve also gone through the New Device procedure once more, this time, not even setting the Somfy remote into programming mode, and sure enough, it went through the device adding w/o any error, and of course, no working control over the blinds. It’s as if Homey isn’t picking up any RF signal.

Thanks Adrian, I’ll check on the link you provided. I’m afraid if it’s using encrypted data, there’s little hope to have it integrated.

Hi, have you been able to solve the problem?

Do you have a Somfy Tahoma, Connexoon or Connectivity kit?

To solve this, I’ve bought the Somfy connectivity kit, which links without any issue with Homey and allows having Flows controlling the Velux blinds, windows and even the external terrace blinds.

The connectivity kit goes for about 70EUR and does the job nicely.