Add Smoke sensor Heiman hs1sa-e zigbee?

Hi, I bought 5 smoke sensors from the brand Heiman. Modelname is hs1sa-e zigbee.

I added 2 smoke sensors to Homey and Homey suggest the app KaKu from Trust.
Sensor is added, but the flow doesn’t work if I test it with the button. I reset it and tried again to pair it but the same issu.

I see a lot of topics but they’re very old. The only app of the Heiman in Homey is for the z-wave models.

Can someone help me?

Please share your flow, so we have a better idea of your problem.

These are some tests

Nothing wrong with your flows, especially the second one cannot be easier.
How did you test? With the blue triangle in the flow, a test button on the alarm or actually with smoke?

You can make the test even easier by starting this flow with the triangle button. That flow shall work as can be seen by the green check mark :white_check_mark: in the notification card.

If I test both flows with the test button (blue button) in the flow. Everything is green. But is I use the test button on both smoke detectors nothing happened.

Using the developers tools you can test the communication between Homey and the smoke alarm. But as paring is successful I expect the communication is Ok. Otherwise ask the supplier, as the manual does not give any clue.

From a Zigbee implementation point of view, there is a distinction between a IAS zone status update for a real (smoke) alarm and a test notification / alarm.

Pressing the test button will likely only send a status update that the device is in test mode and therefore not trigger the smoke alarm capability within Homey.
Some apps have implemented a way to capture this test notification / alarm.

IMHO the best way to test any smoke sensor is to buy a smoke spray bottle to actually trigger the smoke sensor (and with that the smoke alarm).

1 Like


Im not sure 2 years ago i switched to home assistant. There is both versions supported.
In homey just a z-wave version in that time.
Now im not sure.


I test it with test gas. The smoke detector is beeping but nothing worked on homey

1 Like

Then either the sensor is out of reach of Homey (unable to communicate) or there is an issue with the implementation of this driver…

It was 3m away from the homey

I bought FRIENT smoke detectors :slight_smile:

1 Like