24h format on homey pro

Just set up my new homey pro, and for some reason the app uses 12h format instead of 24h. Is there a way to set up the ap to use 24h format?

Maybe your location is wrong in your settings in the Homey app? :thinking:

A bit of explanation to Wim’s message:
The time format + timezone are derived from the location where Homey thinks it sits.
Sometimes it could just not be determined somehow, and your location is set somewhere in an ocean :joy:

It is a simple fix:
Go to location settings, move the map to set the pointer to an other timezone, wait for a minute, and then move the map again, to set the pointer to your location / somewhere in your timezone.

EDIT: time format seems different in app v6.x and v7.x

When things went well, the clock should be set to your country’s 24h format (at least that is what it should do and what I expect it to do :hugs:)


Had the same issue with timeline entries showing up in 12H AM/PM format on my HP23. Unfortunately it seems that the date/time format depends on the Language you select for Homey. I switched from English to Dutch and the timeline entries were displayed in 24H format. I prefer an English UI though, but then Athom would need to make Time format customizable.

1 Like

I doubt it follows languange setting, at least I have 24h format on my HP19 despite language set to english.

I guess hope this will be fixed once Settings > Location becomes available on HP23.

Location is available, but just not in the WebGUI yet, but only in the mobile app which is the main way to configure Homey. (WebGUI is the only an additional way and still very much a work in progress)
But yes the time is currently based on the language the Homey Pro (early 2023) is on, you might want to contact Athom about it so they can add that option into the new Mobile app.

Thanks for the tip! I am a newbie on Homey, just received my HP23 a week ago. Since then I have been so excited about developing Advanced Flows in the WebGUI that I have hardly used the iOS app. :innocent:

Same here, that’s why I thought my hints would do the trick.
Appearantly the time format on Pro 2023 is language dependent now.

Changed the language setting from dutch to english and timeformat changed from 24h to AM/PM display on my Homey PRO 2019…

Now here also (Pro 19)
But it was 24h format until recently?
I’m on v8.1.3 firmware since februari…
But I just installed mobile app v7.x version yesterday

It probably has to do with the app version?

v7.x version:

v6.x shows 24h format with English language setting:


I had my homey set with an adress that should have 24h system. But still had 12h system. Changed the language to norwegian, et voila 24h system like we have in civilized societies. But I’d much rather have the language in english as it helps with fault tracing. But if it commes with the bagage of 12h clock its thats a hard pass. It really should be possible to set manually if youre so unfortunate that you are from the US and only speaks english you’re stuck on 12h clock either way it seems now.


I asked on Slack and have some good and some bad news:

Bad: it’s a bug :beetle:
Good: will be fixed soon™

Screenshot from 2023-05-19 23-43-33


Thats great. Will help me when I need help with my flows eventually.