2.0 Bug: Fibaro RGBW Modul cannot read property 'strip_type' and "Index out of range"


Since version 2.0 the RGBW Module is not working properly anymore.
I tried to re-add the modul to the system but now i am not able anymore to set the correct settings back.
In version 1.5 everything was working fine, and it was possible to set those properties.
Now i get the error “Cannot read property ‘strip_type’ of undefined”

The problem occours when i set the input configuration to “Tuimel schakelaar (schakelaar status gebaseerd)”

Also i am not able any more to set a advanced property: 14,4,61166
I get the error “Index out of range” but in version 1.5.xxx i was able to make this setting.

Here some screenshots from the new and the old configuration:

Error 1

Error 2

Settings v1.5.x

Kind regards,

This is not specific to the RGBW-module.
Lots of users (including me) seem to be having problems with random modules right now.
I have 6 identical Fibaro Dimmer 2’s, only 1 has the same problem you are having, unable to save settings.

Create a ticket and hope it gets solved soon :slight_smile:

Same here… Sinds the upgrade my lights are not turning off… I need to manually turn the light on and off 20 times in the app or so and then finaly they are off… Restart of the app and power also dosn’t help much. At first it works and second time the same issues…

Ive already made a issue ticket on github. I hope they will make update very soon.

my lights will turn on but it wont change to yellow/warm white.

re added my rgbw module, didnt fix the issue.

Green is not green anymore, problem occured with homey version 2.0

I have opened a issue with Athom for fibaro app but they are not doing anything with it. I’m really fed up with them and the stupid excuses.

I am considering changing Fibaro RGBW to Shelly RGBW2 controller