Widget app

Is it possible to create a widget for android phones where i can see and switch my lights or other things. Then you don’t need to open your app al the time and search for everything.


If you want to learn a thing or two and invest some time you could read about the possibilities here: [TUTORIAL] Using Tasker / KLWP together with Homey

I use webhooks for that! The blog over here gives some information about webhooks: https://blog.athom.com/opening-apartment-door-remotely-homey/?lang=nl

I use the Webhook manager app: https://apps.athom.com/app/webhook.manager
And on my Android phone I use the app HTTP Requests shortcuts: https://play.google.com/store/apps/details?id=ch.rmy.android.http_shortcuts

It’s a bit work to set up, but with this you can trigger every wlow you want from a button on your phone.

I would very much like this too.
For now I use IFTTT for it.works like a charm, but a bit slower that as it would if it worked inside the hkmey app.

IFTTT has implemented it really nicely:

  • first Connect Homey to IFTTT
  • in the IFTTT app create a new applet with “this”: Button widget (red icon) -button press and “that” Homey - start a flow (i.e). It reads the flows on your Homey, so you can choose an existing flow.
  • evt change the button title (length is limited on Android) and press finish.
  • You can now choose “Add homescreen widget” and add it to your home screen.
  • The first time you press this newly made button, you can choose the action you would like activate with this button.

Such a way of adding widgets to your home screen from within the Hkmey app would be a very nice way of implementing this!


Yes, I would like to have this too. The app is fine for advanced use, but there is too much clutter. Some icons on your android home screen would be nice. I tried the HTTP method once, but is was not always reliable. Tasker is much too complex imho.

Best way of implementing this would to be to add the ability for a Virtual Device to get dragged onto the home screen as a widget.


I Hope there will be android widgets too. The sooner the better! It is just a click to much to start a flow at the moment.

Kind regards, Joris

Have a look at this

In the latest app update you can create widgets now.
Just tap and hold a free space on your home screen, choose widgets, search for “Favorite flows” (looks like a green play-botton on a white background) and cboose the flow you wanna use.
Make sure this flow is set as a favourite flow within the Homey app first.
Now I only have to do is figure out how to change the widget icons and names… :stuck_out_tongue_winking_eye:


Henk, leuk je hier tegen te komen. Ik heb een Homey sinds een paar maanden.

1 Like

Grappig betere uitleg dan die van homey zelf, want een homey widget is er niet alleen de favorit flow widget. Is ff zoeken als je op homey widget zoekt.

@Fons_de_Rond @Wim_de_Haan

If you could please keep the conversation in English as much as possible, then more people will be able to participate. If you would rather not or can’t communicate in English then please check out Non-English boards at


No problem

Widget resizing on Android is coming very soon!
Beta can already be tested; see screenshot below:

Has not yet arrived (as beta) on my Android phone, but on my iPad an update has already arrived with the above changelog.

I hope the gon a make nice icons for the widgets in the future. I don’t realy like al the play buttons on my screen. For now i use Macrodroid for the widgets and have nice icons for al the widgets.

Hi, has anyone hade issues with the play buttons? I have a flow that puts out the lights in the house. I triggers two other flows, one for each floor. When i hit the play button it changes to a check, but it does not change back to the play sign and therefore I can only use the button once. Then I have to ad the widget again to make it work, ONCE. Whats up with that?

Yes! Same overhere.

1 Like

Same problem here.

1 Like

Unfortunately, the community won’t let you upload video’s, but it works fine for me. Reverts to a play sign within 2 seconds. I’m on a S9

Has anyone an idea how to solve this issue?

Contact the company which sold you the product?