Timed flows do not execute, most of the times

I have had the same problem since yesterday. The kitchen and living room heat is turned up at a certain time, depending on whether it is a weekday or not, and given that anyone is home.

This is a Homey (Early 2019) with fw version 4.2.0.

Time zone and time are both correct

No changes have been made to the flows for a few weeks (since replacing a heater + switch with a wifi heater), and they have worked fine since creation. Our phones were turned on at the time. I have added logging for presence at the same time tomorrow to see if that is the problem, but I see @Renzo does not use location in the flow, so maybe that’s not it.

The built-in localization of homey is relatively unreliable, so many users use other options.
Have you ever tried your flow without localization?

@fantross No, not this one. I will check the logging tomorrow (also made a separate flow to log presence), and if it indicates presence is a problem, I will change it. I have used a virtual presence switch controlled by HomeKit earlier.

Localisation is perfectly stable here, with iPhones. Except last time it was switched off in settings. Maybe due to a restore of an iPhone back-up.

It’s weird. I delete my flow and try again tomorrow morning. Today I’m learning Norwegian :smiley:

Ahem. Norwegian :smile:

I stand corrected! I have a lot to learn. Sorry! :wink:

1 Like

@Renzo, the problem with the localization was not related to you, because you don’t use it, especially not in the shown flow.
You should check the homey time and homey location. Did you?

@Axel, I use actually also the localization with Apple HomeKit via HomeyKit App. And it works great.

I ment in general. The geofencing is quite accurate.
Yes I did. It’s all correct.

So could you please make a new flow only for testing like I did.
Time 16:20 o’clock

Could it be the difference between “7:30” versus “08:44” where the latter starts with a zero?

The 2 simple flows I have that are supposed to switch a qubino plug on at a 09:30 in the morning and off at 21.30 in the evening also stopped working both some week ago, so nothing to do with leading zero. Now happens by pressing the button on the plug manually…

That would be very lousy programming on Athoms end.

@Renzo, did you try a new simple flow?

As this problem is now reported by 3 people, it may be a problem caused by Homey.
My recommendation: Please contact the Athom .

I reported it, but my original flow is deleted.
@Hans4 maybe you could do the same? Do that here.

1 Like

Well, my flow has worked fine since I added the logging. I guess Heisenberg will be happy :confused:

Glad to hear. I hope the cat is still alive too, or haven’t you looked there yet? :slight_smile:

Doffen doesn’t seem stressed out in any way


Support has looked with me. It seems that the time of 7:30 is cursed. Testing did work, obviously. But when I programmed the flow at 7:31 it ran this morning. Very weird.