The new Homey Pro — Ask Me Anything

@JPe4619 no not remove.
Homey Pro (early 2023) will show a button when you open the device to repair it, that will also fix all flows etc. I guess it is more like a replace function, but they call it repair.


From januari blog:

Start-of-April blog:

No zigbee mentioned here, but it still needs re-pairing if I’m correct.

so we have to redo the flows

My info was wrong, do as Caseda and Peter said, don’t think you have to redo your flows

Nope, you only have to re-pair your device

that’s to say ?

Anyone already noticed that after migration by every device the “flows” tab empty is? So, I cannot see anymore in which flows the device is used.

Yep, reported as well but if you can submit report to Athom, would be great.
We complained about that on SLACK only…


I filed a report/bug using the reporting system in the new app

Hello! I just received my Homey Pro 2023 and ZWave region is locked in app, I can not change it to EU as I made on my old Homey Pro!

Left (Old Homey), Right (New Homey)

Found a way to bypass this, Turn Off Geolocation for Homey App, change in app geolocation to France for example, and set English, then restart Homey and ZWave Software Region will be EU, then I added all my EU devices and revert all settings and geolocation to my current. Now all works!


Good morning @Peter_Kawa ,

and how to do that?

Share a new security key? By repairing the Zigbee device, see post #643.

1 Like

Are there OTA options on Zigbee and Zwave? In case, hove does it work?
In case not, will this be implemented i near future (hopefully)?

In the YouTube video “The New Homey Pro - Ask Me Anything” (Link) these questions were answered. Afaik this is still the current status. So I guess nothing in that direction will be realized in the near future.

But with an Aeotec Z-Stick Gen5 (+), the Aeotec App and a PC you’re able to do firmware updates of Z-Wave devices without excluding them from Homey. At least that’s how I understood it.

For more information, please visit the following website:
Z-Stick Gen 5 (+) as Secondary Controller in Homey


Hi! GOT my new Pro 2023 today. Updated it to rc110. However I get the “zigbee is busy” whenever I try to do something with zigbee (pair, repair, check network in dev tools +++).
Any hints to get zigbee in a working state?

I had the same bug. But updating to rc110 fixed it for me.

I was hoping it would be fixed for me too. Also tried restarting, but same issue.

PTP ? I have Zigbee working for me but it’s kind of unreliable …did you restore already from HP19 or starting from scratch? …you can always try backup, Gomwy reset, restore back.