Strange Power measuring

I have an Fibaro wallplug and it measures the power on my TV. If the power goes below 30 watt it should turn on some lights. This works. After i shut down the lights the flow turns them on again and again and again and again. I only want them to turn on once. Any tips ?

Why its stange power measuring??? it does what your asking for!!!

If you dont want you lights go on after you set them off, you have different option for, for example

Make a “boolean”

And in the THEN set boolean to true.

New flow…

If boolean is true

Then speciefike appraten aan.

The only thing you have to set the boolean false somewhere again otherwise they wont go on the next time, for example aftere the tv is set off

sorry, left a peace of information out, the strange thing is that the power level after shutting down my tv is 1,1 - 1,3 watt. The report threshold in the advanced settings on the power plug are 15 watt, so my guess is that anything below 15 watt would not be reported and therefor would not trigger the flow repeatedly.

Would setting a boolean fix this? it would also be triggered every time same as my flow, or does the boolean work different?

you have a logic card less then 30. so 30- 1.3 is more then the 15 :wink:

its not reporting when it change less then 15, but for you its changing arround 28.5

Afaik, the report threshold value is the amount that the power changes before it is reported directly to the controller, even if the regular time to report is not met yet (another setting). So maybe you should set it to a bit higher value.

First make the “boolean”. Go to more/logic. Then click the + sign on the top right. Give it a name, i used “Power tv” in this case. Click the type and choose yes/no. Click the save mark on the top right.
Then make 3 flows like this:

This way the boolean will only turn to yes when it was no and vice versa.
The rest of the cards u have to add urself, like turning the lights off. Plz be aware that with the “Turn specific devices on” card u will turn on ALL lights in that zone, in this case ALL lights on the eerste verdieping WILL turn on.

ok, will try this, thanks for the help guys!

I made the boolean and the flows. So the last two nights the lights were not on after shutting down the TV. So yesterday when i shutted down the TV i looked at insight for the actual power measurement:

It shows the power consumption is low, at least below 30 watt (i think its actually almost zero) so the lights should be turned on. But they where off.

5 minutes later i checked insight again and it shows something else:

It seems Homey is not correctly measuring the power consumption for about 5 minutes.

Any thoughts?

The top graph doesn’t look like it has 0W as the minimum value on the Y axis, but rather around 50W.

Are you sure your TV doesn’t have some sort of “soft power-off” where it remains active for a while until shutting down completely?

The second graph is the same, it also doesn’t go to zero. As far as i know there is no Soft Power Off, but i will check this with life measurement tonight.

Before i noticed the light did turn on after about 5 minutes. Could this be an effect of the changes Athom made:

In Homey v1.x insights were stored indefinitely, simply added to a long list of entries. This gave many problems because simply put, Homey’s storage is not infinite. There’s about 1.6 GB available for user data, and minus apps and voices approximately 1 GB remains. When you have quite some devices running for a long time, you can easily see that storage becomes a problem.

In Homey v2.0 we set out to solve this problem once and for all. A simple but brilliant solution has been implemented that averages insights over time. The farther you go in the past, the more we average. The smallest interval is 5 seconds, which is visible for the last hour. The largest interval is 1 day, which is used for one or more years. Which is a fine tradeoff, because who want’s to see their energy usage at 12:31 on Thursday more than 2 years ago? We definitely don’t!

Because the last graph shows a step of about 5 minutes before going down.

The data compaction in Insights is merely to limit the size of the database, but it should not in any way have any influence on how (fast) flows are triggered.