Start a flow on a agenda item

It is still not 100% clear to me what your issue is. I created your flow and added different time slots in my agenda. It gave me the correct information.

I think when you are using reminders, this is also seen as an activity.
Otherwise contact the developer of the app. Maybe has has an answer to this problem:

Only way I’ve found to do this is using Google Calendar and IFTTT not a great solution but their isn’t a huge amount of lag time depending what you’re using it for.

Setup a Google Calendar agenda item, link to IFTTT then can If Google Calendar item starts, start Homey flow.

Thanks for testing.
For now I’ll wait until tomorrow for the 12:00 event, and see what happens.
If that’s correct, I will know there’s “something” wrong with my calendar entries.

I once had a problem with my Apple Watch (after an update) not picking up all entries, and recreated some, and added the date to the new ones. This is why I know when I created some of them.
Today I again did this to the 12:00 entry.

I made also a test for tomorrow 12:00. All test for today worked fine with Apple Calendar. I made events on different systems: iPhone, iPad, Mac Book Pro and iMac. All worked fine. :slight_smile:

Should be an idea to share a calendar item on how you entered all information? And then the one which give you troubles.

@Nigel_Scott,

The app woks fine with all options of the app,. No issues so far. I do not want te work with Google. I prefer Apple calendar.

One thing I just noticed: all not correctly working events have an exclamation mark (!) in them…
That’s probably not the reason, but… You never know!

First I’ll see what happens tomorrow, but if I still have issues, I’ll test without an exclamation mark, just to be sure.

The app works with apple calendar?

Yest it does. :slight_smile:

  1. Go to https://www.icloud.com/calendar/ or to the calender on your iPhone or Mac.
  2. Click on the icon next to the calendar name in the left pane
  3. Tick the checkbox for Public calendar
  4. Copy the webcal:// link
  5. Replace webcal:// with https://
  6. Paste the ical link in settings of Homey app
1 Like

At 12:00 I got the expected push-message.
Finally!

This means I just need to re-create some non-working events.

ok this sounds good. Hopefully by re-create some non-working events the problem is solved. :slight_smile:

Yesterday there was an app update to V0.1.1. From now on I am not able anymore to sync my calendars with Apple. Are more people have this issue?

I put an een event in in my agenda, en set the sync on an different time & did “test”.
And I’m still getting messages from my homey.

Ik need to investigate if and how to sync more often but for now is once a day is enough…

Unfortunately I can no longer sync anything. Yesterday there was an app update to V0.1.1. Now the sync no longer works. If you are still on V0.1.0, do not update, otherwise it will no longer work for you.

I’m already on V 0.1.1

@J.W_Hoogervorst and @RobvandeGoor, please keep the conservation in English, thank you.

Sorry… I have translated the text. Same topic in 2 different groups… Dutch - English…

1 Like

I found the Dutch one. I think it’s easier for us to continue there.

2 Likes

A new update of the app is available (V0.1.3)
If you had sync issues using the Apple Calendars, please delete the link of the calendar in the app and copy and paste it again.
The Apple Calendar url is case sensitive. All karakters put in lower case as result the url did not work anymore.
The app is from now on also available in the Dutch language.

1 Like