Setup is always restarting

Hi all

Got a brand new Homey Pro today.
I do the following steps:

  1. Power on
  2. wait until setup voice starts
  3. go to
  4. select the wlan
  5. enter the password
  6. homey is connecting to wlan (i can ping homey for around 15 s), blue color
  7. after around 15s, homey is going back in setup mode, yellow collor

What is wrong?

It could be that there is a problem with the WiFi. I know the older models MUST be connected to 2.4Gnz and if a 5ghz exists, that could cause a problem. There should be some topics about that if you do a search.

Else, keep it upside down until you hear a countdown and wait until it resets. Then try setup again.


Thanks for your help. Homey can connect to wlan, i can see that my router assigned him an ip and i can ping this address. But after around 15 seconds, homey is going back to setup mode.
If i keep it upside, nothing is happen, maybe because he is in setup mode?


As far as i know, keeping it upside down for some time should always start a reset procedure…
Is your SSID the same for both bands? Then it still can be a problem of the Wifi connection.
Or do you have a traffic blocker in your network, like a Pi hole or a firewall that prevents some traffic to the Athom servers?

i also tested with a mobile hotspot. same result. :frowning:

Last option i can think of is check if your adapter and/or cable is faulty, that is also known to give weird problems.
If that is also not the cause, then i am afraid there is only one way left: contact Athom support and see what they have to say. :thinking:

Can you disable 5ghz, maybe that helps. Or ptp for at least 15 min and try restarting again. Very annoying when you get a new device and it acts like this. No warm welcome for you.

You might try another USB cable.
If nothing changes you can try another PowerSupply (PS) that can give at least 2A by 5V.
For instance an ipad PS.
If than Homey stays on your PS is faulty.
Otherwise it’s your Homey.

Keeping it upside down worked in my case. I was unable to install my Homey as well a few months back, but the reset solved this. You may have to wait a few secondes before the countdown starts, but it will start. Keep it upside down during the countdown. It doesn’t matter that Homey is in set-up mode, it should reset.

Thanks to all for the help. I was back in the shop, they replaced my homey. Now with the new one, everything is working fine. It was a problem with the homey itself.