Roborock app

It there someone who is developing or interested in developing an roborock app? I’m having a roborock s7 and the old Mi app has no support for s7 or the early model s6.


Yes, I would be very interested, and willing to donate to a devoper who creates this app…! :slight_smile:


Yeah me to. :smiley:

I suggest to post app requests here

1 Like

I do think that should be the right place, absolutely right, @Peter_Kawa.
But has there ever been an app that was developed initiated by a request there…? :wink:

1 Like

I have no clue Henk… I think it matters how many beers or coffee you want to donate :wink:
Just kidding. I think few would invest the many hours needed to develop, test en maintain an app for a few peeps. In other words, if it’s too rare, changes of an app drop. Roborock seems a populair device though, but idk how hard it is to connect with Xiami’s api / software

Haha, perhaps… :wink:
I have always donated and will do in the future to developers I appreciated. Would be nice if everyone did so too… :smiley:

Yeah me too! please also add the S5 max because this unit is also not very supported yet.
I think it is the same software / token as the newer S6 en S7

Always open to donate to a project like this as well. The workaround with an alexa skill is kinda working, but a bit limited (can only start cleaning and dock, no coordinates etc)

Well, that’s a bit of a point of perspective: my vacuum robot itself simply has no other options than ‘go clean’ ‘stop’ and 'dock’:sweat_smile:

Yeah same here, so that is exactly the limitation i want to overcome, but i can make it do these things through the alexa skill, which i control through homey (Alexa app created by @Jamie :+1: )

It’s far from what I would ultimately want for the Roborock, but it’s better then nothing, and this workaround is doing just that

No sorry, I meant my robot doesn’t have any other option, at all. Even in it’s own phone app.:wink:

Hi guys!
Are there someone that owns a Dreame Robot vacuum cleaner (like D9 or L10)? I managed to get my hands on the new L10 Pro that was recently released, a great machine. Dreame is a sub brand of Xiaomi (like Mijia and other brands)
I knew from the get-go that it would be problematic to include it in Homey, but for once I didn’t chose a product on how well it is integrated in my smart home. I hoped that it might work since the Dreame is added to the Xiaomi Home app though.

But I installed the Roborock app via CLI and successfully retrieved the token, and got it into Homey. :slight_smile:

Unfortunately, I cannot control it in anyway, not even get information about status and stuff like that.
I would like to get in contact with the hero that created the roborock-version of Xiaomi Home, is github the only way?

All contact info can always be found at the bottom of the app page.

Here you go:

Oh, my bad! Thanks

1 Like

Small update, since it doesn’t seem there will be S7 support anytime soon, i’ve been looking for other ways to get it done, so far i’ve managed to install iobroker and setup the mihome plugin and am able to control the S7 from there (still limited so far), currently having a look at http requests between Homey and Iobroker, to see if we can get it started from Homey.

NOTE: You do need to switch to the MiHome app, the Roborock app isn’t supported (you can enter a token manually, but i haven’t figured out how to get a Roborock token, so might work as well)

Update: Doesn’t seem to have way more functionality then my other workaround through Alexa from Homey

If you are interested in an solution like that Xiaomi Roborock S5 - Room control by voice via Alexa / Siri via homebridge let me know.

Well that’s a pitty… Just updated my S5 to a S7 thinking this would work just fine since the S5 was working. After extracting the key and installing everything, this failed to work. Ran into this topic :frowning:.

Are there any updates regarding this? I loved the ‘move robot to’ card but even just starting it would be great, it’s painfull investing in something that’s not compatible haha! (yes I know it’s my own fault).

Did you even manage to get the S7 connected? Can you share how? So far i’ve not been able to even get it to connect (my s5 worked fine, and i tried the same steps to get the token)

I was able to extract the token, but after using this in the Xiaomi app that Homey supports I was unable to link the vacuum S7 to it.

According to this thread and other community posts the S6 Max and newer are not supported.

I found a tutorial on how to install a unofficial Homey app and connect the vacuum to this, soo far I managed to do this but I have a failure in pairing session.

Keep you posted. I think this evening I will get it up and running.