Homey Community Forum

Ring Security - Extend Heimdall with Ring Security products

I see. :frowning: but i have to say, that the integration of the keypad works like a charm. also heimdall is amazing and i love it. thank you so much for your incredible work. :clap:t3:

2 Likes

Thank you so much for this, I have the 2nd Generation Ring Keypad and I’ve been hoping to see an integration for the Ring Alarm system ever since I bought my Homey last year, this is wonderful of you to do. Developers like you are the reason we can enjoy all this amazing technology :heart:

2 Likes

So, good news!
I finally managed to get the communication from Homey to the 2nd generation Ring Keypad working. Not all functionality is there yet, this keypad uses fixed times for the Alarm Delay and Arming Delay so I have to figure out how to match that to Heimdall where the delays are flexible. That also is a problem for the Last Door Function so that’s not integrated either. Lastly, I’ve not yet added functionality for when the Alarm is activated.

What is working you ask?
Well, the Surveillance Modes gets displayed correctly and the Sensor Active at Arming message works (and while I was at it, I added a setting to enable/disable ignoring it, for both Keypad Generations @Rob_Bruining)

I’ve not submitted this version to the App Store, but it is available at Github so if you know how to CLI install an app you can get it and test it, I’ve not done thorough testing yet so I hope some people here can help me out with that.

What was the problem getting it to work?
This Ring Keypad version uses the Z-wave Command Class Indicator Version 3 which is very different from the Version 1 used by the 1st Generation Ring Keypad. Thanks to @TedTolboom I was able to write code in the form the Indicator Version 3 expects it, only to find out that Homey doesn’t support Version 3 of the Indicator Command Class (yet) only Version 1 and 2. Luckily @tjallingt stepped in and helped me out with some code to send Z-Wave command equivalent of what the Indicator Version 3 would do. Thanks to both!

2 Likes

Thank you Danee. I cannot test it, because I don’t know how to work with CLI install. If there is a test version that I can download with a link, I will test it, but otherwise I will wait for it.

I have a question. The Ring v1 keypad works very nice. I also use it as a siren. But when the alarm goes off. The siren works for I think 1 minut. When alarm is there and I directly set every thing off , I cannot disable the siren of the Ring keypad. After a specific time the alarm stops. I disable the alarm from my phone and not from the keypad.

When you say disable the alarm from your phone I guess you mean by either clicking the Alarm Off Button or clicking the Surveillance Mode Switch, am I right?
To be honest I think I didn’t test that when writing the driver for the Ring Keypad, I only checked by setting the Surveillance Mode to Disarmed, that definatly stops the sirene so please use that method for now.
I’ll have a look in the Ring Security app how to fix this, will post a follow up in the Ring Security App topic

I do both alarm disabled and surveillance mode disarmed…

Hi Rob,

I’ve not been able to reproduce and when checking the code I found I already added code to stop the Sirene when they Alarm State was turned off without changing the Surveillance Mode but since my local version is already ahead of the published version I’m not sure it is already available in your version. Can you tell me which version of the Heimdall app and the Ring Security app you are using?
Also, I’ve made changes in how the Ring Keypad (V1) can be used as a Sirene for Heimdall, there is a chance the setting and actual working are not aligned. To be sure that’s not interfering could you please remove the Ring Keypad from Homey and add it again?

Hi Danee,

Thanks for your reaction. I have Ring 0.2.0 and Heimdall 2.1.0. Maybe that’s the difference.

0.2.1 is latest on gifthub

I will probably submit that version to the app store soon. It has some changes and partial support for the 2nd Generation Ring Keypad.
@Rob_Bruining its still my advice to remove and re-add your keypad, can you let me know if that fixes your problem? And just to be sure please change and save the setting for the use as a Sirene.

New version published:

Version: 0.2.1 Beta

  • Support for Ring Keypad from the 2nd Generation added
  • Added setting to suppress “Sensor Active at Arming message” on Ring Keypads
  • Reorganised Ring Keypad settings
  • Code cleanup

Thanks to Robbshop I have been able to add support for the 2nd Generation of the Ring Keypad.

In this version the basic functionality is added but some functionality will be added later, most noticeable the option to use the 2nd Generation Ring Keypad as a Sirene. Compared to the 1st Generation Ring Keypad the 2nd Generation Ring Keypad is missing some options so I have to figure out how to enable certain functionality, if possible at all. On the other hand it’s much better looking and more importantly it has proximity detection so it lits up when you get close to it when its dark so I still prefer this new version.

Also added in this version is an option so you can suppress the “Sensor Active at Arming message” as per request by @Rob_Bruining (Github Issues #3)

And lastly, in preparation of a new function for the Ring Keypad (1st Generation) I’ve reorganised the settings page.

Thanks Danee,

I will try it today or tomorrow. I also installed the new version.

So I can disable the sensor message. Thnx for that.

Rob

1 Like

I tried and it’s working. Thx

Hi Danee,

First of all, let me express my appreciation for your coding of Heimdall and this Ring Security app. Very nice work! I’ve been using Heimdall since I bought my Homey back in 2019.

Some days ago, I found this treat as I was looking out for a keypad that should replace my poorly working Zipato mini keypads. I’ve bought a Ring Keypad v2 but have some issues with it. The keypad is included successfully to Homey. When the alarm is (un)armed, I see on the keypad which one is active, but I can’t arm or disarm using a pincode. I’ve added the flow mentioned here to arm without pincode, and that works fine. However, in that case, disarming from the keypad does not work. In Heimdall, I’ve set a 6 digit pincode for the administrator. To (dis)arm, I first enter the 6 digits and then push one of the three buttons on the upper side. It looks as if the pincode is not sent to Heimdall. In the Homey Developer Tools, at the moment I want to arm/disarm with pincode, I see communication from the keypad in the logging. I’ve already re-installed Ring Security, removed/added the keypad, all without success…
Any ideas to get me going?

Thanks already!

Hi Frederick,

It should definatly work without any flows, lets find out what goes wrong. Can you please check in the Ring Kepads settings that Integrate with Heimdall is turned on (better yet, toggle it to make sure its enabled)
If that does not help, can you please click Restart app in the apps settings and after a couple of seconds click Create Diagnostics Report?
Next, on the Kepad; enter your pin, select a Surveillance Mode and send me another Diagnostics Report.
Please let me know when the reports are sent, thanks.

Hi Danee,

Thanks for your reply. I had tried to toggle the integrate already. Anyway, I did that again as proposed, without success. I’ve created two reports and will send you the identification separately.

Kind regards,
Frederik.

Danee,

Just to let you know that it works now. I’ve deleted the Ring Security app and reinstalled it from Ring Security | Homey. When it wasn’t working, I’ve installed the app from the CLI. This is now the only difference I can think about.
Looking out for future improvements already. I’ll donate something for Heimdall and this Ring Security. Keep up the (very!) good work.

Frederik.

Hi Frederik,

That’s the reason for sure. In order for the Ring Security app to be able to talk to Heimdall it needs an API key that isn’t available when doing a CLI install. I will add that to the opening post.
Thank you for your donation, much appreciated!

Cheers,

Danee