Re- detect configuration Fibaro Zwave sensor


At my stairs i have and old movement sensor; it’s working fine but it has one (annoying) flaw:
The time between detection and wake-up for new detection is too long/not good configurable.
I cannot get the time between detections shorter than 90 seconds.
So the only choice i have is to leave the light on the stairway on for at least 90 seconds.
That is much too long.
Off course i told Homey to switch off the light 20 seconds after detection. But when you f.i. re-enter the stairs within 70 seconds (90-20) there is no detection (because the sensor is still at ‘sleep’.
Also when you are a longer time busy on the stairs (vacuumcleaning ;-)) the light goes out after 20 seconds (correct by Homey) so now you are standing in the dark.

So i am looking for a replacement and i am interested in Fibaro.
Question: Does anybody has any experience with this sensor and the configuration capabilities to set the time between detection ? (shorter than 20 sec :wink: )


I guess you mean the Fibaro Motion Sensor (FGMS-001), correct?
The “re-detection” time, Blind Time is the correct name, is set to 8 seconds by default, longer is not possible at all. But maybe I misunderstand your problem.
However, what also influences the detection is the setting of the sensitivity (parameter 1) and the pulse counter (parameter 3) in relation to the time window (parameter 4).

Hi @fantross ,

Seems that the Fibaro is capable of what i am looking for.
I am going to order one and experiment with it.


Ok, I misunderstood you a bit. I thought you have already the Fibaro Motion Sensor… :joy:

Normally I would recommend the motion sensors from NEO Coolcam, but the sensors that are currently shipped probably only detect motion after 3 - 5 seconds according to some users. But I don’t know if it’s the sensor itself, the settings of the sensor, or the Homey app.

Why do I not recommend the Fibaro motion sensors without reservation? I still have 4 Fibaro motion sensors in use, the rest are NEO Coolcam motion sensors (old version). Now and then it happens that the motion detection does not reset itself. Only when the motion detection is activated again, it works again. But this happens only 1 to 2 times a year.

But because most Z-Wave motion sensors can actually be adjusted very precisely, you might also want to take a look at the Aeotec Tri-Sensor.

I have heard that some users have had good experiences with it.

Thanks @fantross

Gladly I read your response in time.
The sensor causing my problem is unfortunately a NEO Coolcam. It’s blindtime is set to 2 seconds but in real the blindtime is 90 seconds. It won’t adjust according to the settings.
I’m going to take a look at the Aeotec.


No problems with my NEO Coolcam Motion Sensor.
How did you set the “Motion detection ON time (s)”?


Motion detection ON time (s) is set to 5 seconds. But i don’t think this is relevant though ?
Because this only affects group2 devices (so not Homey). Or am i wrong.
My complete settings below:

Maybe you can see something weird/wrong ?


But this is also the time needed for the card “The motion alarm turned off”.
I would try the following settings:
– Bewegingsdetectie AAN tijd (s): 15 s
– Bewegingsdetectie blinde tijd (s): 5 s

As I wrote already, I have absolutely no problems with my 6 NEO Coolcam Motion Sensor.

So maybe you’re flow faulty? In my opinion it’s better to start a timer after cancelling the motion detection. Could you please share your flow?


The flow is quite simple. When the sensor is activated it starts a countdown of (here) 25 seconds.
If the countdown reaches 0 another flow shuts down the lights.

I’ve noticed that, after motion is detected, the indicator of the PIR in de Homey app stays on for a long time (Bewegingsalarm JA) and keeps red flashing. Only after about 30 seconds it stops (Bewegingsalarm = NEE). The parameter involved (Bewegingsdetectie AAN tijd) os set to 5 seconds.

Another funny thing:
When i enter the location, motion is detected. I can see the countdown starts counting down.
As long as i stay at the location (and wave my arms and walk up and down) the countdown is not reset to initial value so after 25 seconds the light go out. As like the PIR says: I saw you already, i am not going to trigger motion detection again.

BUT: When motion is detected and i leave the room for a second and return instantly, there is a new motion detection (the countdown resets back to 25 sec and starts counting down all over again).

Weird ?

In my opinion the main problem is the parameter Bewegingsdetectie blinde tijd (s) with a setting of 0 s. In my opinion, this would also explain the red flashing. Please set this parameter to at least 5 s for test purposes.

Please try this flow:

(Sorry, only in German language!)

The time between Zone became active and Zone became inactive depends on the setting of the parameter Bewegingsdetectie AAN tijd (s). So if this parameter is set to 15 s, then you have to use a timer with 10 s. The result will be, that the light goes off after approx. 25 s after the last motion detection (that’s at least the theory :wink:).

Hi @fantross

Sorry for my late reply. I was busy working.
I am going to try your example flow.
I’ll let you know the result soon :wink:


1 Like

Hi @Fantross ,

Your flow seems to work. Perfect! Thank you very much.
Do you recommend to keep these setting in the device ?

  • Bewegingsdetectie AAN tijd (s): 15 s
    – Bewegingsdetectie blinde tijd (s): 5 s

…or is it better to change them ?

Thanks again, you were a great help.


You’re welcome.
If it works for you I think you can leave the settings as they are.
In the end, it also depends on the area in which you use the sensor and the flow. Should the light be switched off as quickly as possible after the last movement, or should the light remain on for a certain time. Of course, the time setting used in the flow is also responsible for this.