Homey Community Forum

Presence with owntracks cloudmqtt and homey headache

Hi, hopefully i´m in the right place for my problem… :slight_smile:

I have tried homey´s presence and smart presence but the one i see more reliable is owntracks (iphone) and a cloudmqtt + homey app owntracks.

So everything is set up according to guides found in the archive and homey app is getting info from the broker like pushes when fences are changed or get in and out of fences but my main issue is that no flow is triggered (not even testing the flow) based on the owntracks triggers.
The users and geofences are shown in the triggers also and i have a simple flow like leave the fence then set boolean to false and vice versa also set user presence tag to yes or no. But these are not working at all… :tired_face:

In fact i even tried a flow based on homey location, nothing regarding location seems to work…

Is there enyone there using this setup for presence as the archive forum is read-only…

My homey is running on 1.5.13-rc11 and rebooted a couple of times.

Appreciate some help.

Hi Marius, i use Owntracks and Smart Presence as my automatic alarm system and this works great. Have to admit that sometimes after updates it’s hard to get everything working again but restarting Owntracks server on cloudmqqt and the app works for me. If needed i can send you on Slack in a direct message my setup to help.

Hi there and thanks :slight_smile:
I don´t use slack but messenger instead.

I did a restart but it didn´t helped. My concern is that even testing this simple flow is doing nothing. It runs without errors but nothing happens…!?

P.S. maybe i´ll install slack as well :slight_smile:


Try this instead to mark a user as at homer or away
I use similar flows for leaving and other users

And this is the way to switch the alarm system on

Tried, it is exactly what is not working. It´s like somewere the presence function is disabled globally in the system. Nothing with presence works… !? Dont even know what to investigate any longer…:tired_face:

I´ve got Slack installed but dont know what to do next. I´ve created a work place also. Newbie at this…


just to make shure

in homey owntracks, the user name must be the user name for the broker, right. not for my user.
In the iphone app the user name i my user name as i´ve created it in the broker with read/wright rights.

I´ve now changed my home region radius and i can see in the homey logs that it has received the update for radius. That should mean that the connection is ok and the flows should be triggered.

20180929-14:28:12 received ‘{“batt”:96,“lon”:15.498794700734914,“acc”:32,“p”:100.96738433837891,“vel”:1,“vac”:3,“lat”:58.496804440228019,“inregions”:[“hemma_ljungs”],“conn”:“w”,“tst”:1538224085,“alt”:77,"_type":“location”,“tid”:“NE”}’ on ‘owntracks/Marius_Muresan/Marius_iphone’
20180929-14:28:12 We have received a location message
20180929-14:28:12 Set battery percentage for Marius_Muresan to 96%
20180929-14:50:01 getUserArray called
20180929-14:50:06 getLogLines called
20180929-15:05:08 OnMessage called
20180929-15:05:08 received ‘{"_type":“waypoint”,“tst”:1538123042,“lat”:58.496924843754002,“lon”:15.498893865267,“rad”:70,“desc”:“hemma_ljungs”}’ on ‘owntracks/Marius_Muresan/Marius_iphone/waypoint’
20180929-15:05:08 We have received a waypoint message
20180929-15:05:08 saveFenceData called
20180929-15:05:08 Fence: hemma_ljungs changed
20180929-15:05:14 getUserArray called
20180929-15:05:20 getLogLines called
20180929-15:09:34 getLogLines called


In owntracks app in homey do you see in what fence your user is?


As you see i can but i’m aware it shows not always up

Sorry for answering so late, i didn’t get notified. If you need help i can support you if you send me a DM on Slack, My username there is Deadlifter

No problems, i gave up on that and started using the automation in HomeKit instead. That works quite well now.

Thanks anyway :+1:

Hi all,

Because presence is not working at all i tried to get owntracks working. After reading for 2 days and trying to figure out how this work the result is still zero. What am i doing wrong.

I am using a CloudMQTT acount and made 3 users. 1 for Homey en 2 phones . So far a walk in the park. I added the topics with read and write acces.

have edited the post as i am still going forward. All the errors seem the be fixed and the app says “connected” at my home adress. I there a way to see its all working now? I am not sure if everything in homey is fine now?
Do i have to add users in the Homey app?

Looks like there is still an issue. Homey is connected i think

in the CloudMQTT log i find the following which is an error i think

manmanman finally got it to work. tjis is wat i see now in the log of CLOUDMQTT

now some flows and maybe it wil work finally